АВТОМАТИЗАЦИЯ УЧЕТА КЛИЕНТОВ ТУРИСТИЧЕСКОГО АГЕНСТВА

Клиентская база, сложившаяся за несколько лет работы очень разнообразна. Она включает в себя как клиентов с небольшими доходами, предпочитающих низкобюджетные туры (автобусные туры на Черноморское побережье, отдых на турбазах, экскурсионные поездки на 1-5 дней)

2014-06-11

1.79 MB

30 чел.


Поделитесь работой в социальных сетях

Если эта работа Вам не подошла внизу страницы есть список похожих работ. Так же Вы можете воспользоваться кнопкой поиск


ПОЯСНИТЕЛЬНАЯ ЗАПИСКА

ДИПЛОМНЫЙ ПРОЕКТ НА ТЕМУ:

АВТОМАТИЗАЦИЯ УЧЕТА КЛИЕНТОВ ТУРИСТИЧЕСКого АГЕНСТВа.


Содержание
:

Введение…………………………………………………………………………..3

I. Специальная часть          

1. Постановка задачи…………………………………………………………….4

2. Формализация …………………………………………………………………5

3. Описание среды программирования…………………………………………7

3.1. Требования к техническому обеспечению………………………….11

3.2. Требования к программному обеспечению……………………...…11

4. Методика разработки проекта……………………………………………….12

4.1. Алгоритмизация задачи……………………………...….…………...12

4.1.1. Описание алгоритма………………………………………………..12

4.1.2. Структурная схема………………………..…………………..…....26

4.2. Программирование………………………………………..………….27

4.3. Аномалии и защитное программирование………………………….28

4.4. Тестирование и отладка……………………………………….......…29

5. Анализ результатов решения……………………………………………...…31

6. Инструкция пользователю……………………………………………….…..32

II. Экономическая часть…………………………………………………………39

III. Заключение………………………………………………………………...…47

IV.Литература……………………………………………………………………48

V. Приложение…...………………………………………………………………49


Введение.

Туристическое агентство «Отпуск» - поставщик туристических услуг, предоставляет клиентам туры, как на внутреннем рынке, так  и международный туризм.

Основное направление в международном туризме – это Турция и Египет, Таиланд, затем следуют страны Европы (экскурсионные, учебные, отдых, лечение на курортах), на третьем месте горнолыжные курорты, морские круизы и экзотические страны и острова (Юго-Восточная Азия, Индия, Канарские острова и т.д.).

Клиентская база, сложившаяся за несколько лет работы очень разнообразна. Она включает в себя как клиентов с небольшими доходами, предпочитающих низкобюджетные туры (автобусные туры на Черноморское побережье, отдых на турбазах, экскурсионные поездки на 1-5 дней) так и клиентов VIP (высокобюджетные туры).

На рынке туристских услуг эта фирма работает более 6 лет и, конечно, накопила большой опыт в этой деятельности, а также высокий объем информации, для которой необходима систематизация.

Создание автоматизированного  учета клиентов в туристическом агентстве «Отпуск» позволит сделать работу данного агентства более эффективной, упростит ввод и поиск нужной в работе информации, а также, соответственно, повысит уровень дохода фирмы.


I. Специальная часть

1. Постановка задачи

Задача дипломного проекта - разработать конфигурацию в среде «1С:Предприятие 7.7» для учета клиентов в туристической фирме, которая позволит:

  •  Автоматизировать процедуру учета клиентов.
  •  Вводить и хранить данные о клиентах и заключенных с ними договоров.
  •  Автоматически формировать пакет документов для путешествия.
  •  Формировать и выводить на печать документы для оформления и отчетные формы.


2. Формализация.

Для решения, поставленной задачи  необходимо провести формализацию задачи, как  необходимый этап разработки задачи, который заключается в построении структуры справочников, схемы взаимосвязей документов со справочниками и описания алгоритмов обработки.

Структурная схема исполнения программы:

Схема 1. Структурная схема исполнения программы

.

Как правило, разработка проекта реализации задачи выполняется в несколько этапов, начиная с анализа той информации, которая является выходной (формы, отчеты). Только после выяснения структуры и состава этой информации, можно сделать вывод о структуре и составе справочников. Какие измерения и ресурсы необходимо создать в регистрах оперативного учета, данными какого характера будут заполняться, проводиться документы.

На следующем этапе уточняется структура полей в справочниках и документах, определяются правила ввода информации.

Затем происходит возврат к проектированию запросов для форм и отчетов, проектируются формы документов и отчетов. Уточняться измерения и ресурсы в регистрах оперативного учета.

На заключительном этапе создаются различные пользовательские меню, журналы документов, различные дополнительные обработки, определяются права пользователей. В процессе отладки и доработки, возможен возврат на любой этап процесса разработки.

В следующих разделах пояснительной записки все объекты задачи рассматриваются более подробно. Основные особенности ведения учета задаются (настраиваются) в конфигураторе.

В основе данной конфигурации лежит принцип ввода информации в программу «От документа». Это значит, что в программе возможно создание и хранение в электронном виде документов и автоматическое проведение их по регистрам оперативного учета. Технология «От документа»  позволяет вводить любую информацию в программу однократно и многократно ее использовать. Веденная информация автоматически обобщается, что позволяет формировать необходимую отчетность за любой период времени.

Отчеты, входящие в конфигурацию, позволяют оперативно получать необходимые регистры учета и представлять информацию в удобном для анализа виде.


3. Описание среды программирования.

«1C: Предприятие 7.7»  является универсальной системой для автоматизации ведения учета. Она может поддерживать различные системы учета, различные методологии учета, использоваться на предприятиях различных типов деятельности. Система программ  «1C:Предприятие 7.7» предназначена для решения широкого спектра задач автоматизации учета и управления, стоящих перед динамично развивающимся предприятиями.

«1С:Предприятие» является гибкой настраиваемой системой, с помощью которой можно решать широкий круг задач в сфере автоматизации деятельности предприятий. Специфические алгоритмы конфигурации описываются в системе «1С:Предприятие» при помощи программной компоненты Конфигуратор  в программных модулях, содержащих тексты на встроенном языке системы.

Встроенный язык системы «1С:Предприятие» предназначен для описания (на стадии разработки конфигурации) алгоритмов. Результатом конфигурирования является Конфигурация, которая представляет собой модель предметной области.

Конфигурацией в системе «1С: Предприятие» называется совокупность трех взаимосвязанных составных частей:

• Структуры метаданных

• Набора пользовательских интерфейсов

• Набора прав

Метаданными в системе «1С: Предприятие» называется совокупность объектов метаданных, настроенных на хранение и обработку информации о хозяйственной деятельность конкретного предприятия.

Под объектами метаданных понимается формальное описание группы понятий предметной область со сходными характеристиками и одинаковым предназначением.

Рассмотрим объекты метаданных, используемых в дипломном проекте:

• Справочники - предназначены для работы с постоянной и условно постоянной информацией. Примерами справочников в дипломом проекте являются списки стран, предоставляемых туров, организаций –туроператоров, работающих с агентством, сотрудников и др.

• Перечисления - используются для описания постоянных наборов значений, не изменяемых для конкретной конфигурации. На этапе конфигурирования можно описать практически неограниченное количество видов перечислений. В отличие от справочника, значения перечислений задаются на этапе конфигурирования, и не могут быть изменены на этапе исполнения.

Типичным примером перечислений, использованном в дипломном проекте, является тип клиентов (физические лица, юридические лица).

• Документы - предназначены для хранения основной информации обо всех событиях, происходящих на предприятии, и, разумеется, имеющих смысл с точки зрения экономики. При помощи документов отражаются и платежи с расчетного счета, и операции по кассе, и кадровые перемещения, и движения по складу, прочие подобные события. Примерами документов могут служить такие документы как «Договор», «Акт выполненных работ».

• Журналы документов - предназначены для просмотра документов. Каждый вид документа может быть отнесен к определенному журналу. Сам журнал документов не добавляет новых данных в систему, а служит только как средство просмотра списка документов одного или нескольких видов.

• Отчеты и обработки - для описания отчетов и процедур произвольной обработки на этапе конфигурирования может быть создано неограниченное количество форм отчетов. Каждая форма имеет свой диалог настройки, который позволяет определить набор параметров формирования отчетов.

• Регистры (компонента «Оперативный учет»)- предназначены для анализа остатков и движений средств в системе «1С: Предприятие».

Регистр представляет собой многомерную систему хранения остатков или оборотов. Каждый регистр на этапе конфигурации описывается набором измерений и ресурсов.

Под измерением понимается набор значений, которые детализируют движения средств, и в разрезе которых хранятся остатки; под ресурсом – числовая величина, которая является количественным или суммовым значением, отражающих размер движение (остатка).

Под пользовательским интерфейсом в системе «1С: Предприятие» понимается совокупность команд главного меню и панелей инструментов, настроенных на работу с конкретными объектами данных – документами, справочниками, журналами и т.д. Как правило, пользовательский интерфейс создается для конкретной категории пользователей. Цель создания интерфейса – обеспечить быстрый доступ пользователей к той информации, которая необходима им в соответствии с их обязанностями.

Под набором прав в системе «1С: Предприятие» понимается определение полномочий пользователей на работу с информацией, которая обрабатывается в системе.

Большинство объектов метаданных в системе «1С: Предприятие» могут иметь визуальное представление. В самом лучшем случае визуальное представление состоит из следующих частей:

• Экранный диалог, используемый для ввода и редактирования информации, хранящейся в объекте метаданных;

• Печатная форма объекта метаданных (печатных форм может быть несколько)

• Модуль формы -  программа на встроенном языке системы «1С: Предприятие». Как правило, модуль формы содержит алгоритм построения печатной формы объекта метаданных, а также может выполнять обработку вводимой в диалог информации для целей входного контроля, выполнения расчетов и т.п.


3.1. Требования к техническому обеспечению

Для оптимальной работы рекомендуется использовать компьютер с процессором Intel Pentium-III или выше, и не менее 128 Мб оперативной памяти.

  •  печатающее устройство;
  •  VGA-совместимый дисплей (рекомендуется SVGA дисплей).

3.2. Требования к программному обеспечению

Для работы программы необходимо, чтобы на компьютере были установлены:

  •  операционная Microsoft Windows 2000 или выше;
  •  Программа 1С:Предприятие 7.7. (Многопользовательская версия).


4. Методика  разработки программы

4.1.Алгоритмизация задачи

4.1.1. Описание алгоритма

Конфигурация «Автоматизация учета клиентов туристического агентства» разрабатывалось   в среде в  «1C:Предприятие 7.7» с нуля.

В ходе разработки программного приложения были созданы следующие справочники:

Справочник №1 «ФизЛица»

Таблица 1.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Пол

-

Перечисление.Пол

Нет

Паспорт

-

Число

Нет

П_Выдан

Выдан

Строка

Нет

Дата_выдачи

Дата выдачи

Дата

Нет

Адрес

-

Строка

Нет

Дата_рожд

Дата рождения

Дата

Нет

Дом_телефон

Домашний телефон

Строка

Нет

Моб_телефон

Мобильный телефон

Строка

Нет

Тип_клиента

Тип клиента

Перечисление. Тип_клиента

Нет

Справочник №2 «ЮрЛица»

Таблица 2.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

ФИО_рук

ФИО руководителя

Строка

Нет

Юр_адрес

Юр.адрес

Строка

Нет

Факт_адрес

Факт.адрес

Строка

Нет

Тел

Тел

Строка

Нет

Факс

-

Строка

Нет

ИНН

-

Число

Нет

рс

р/с

Строка

Нет

в_отд_банк

-

Строка

Нет

кс

к/счет

Строка

Нет

кс_в_банк

-

Строка

Нет

БИК

-

Число

Нет

email

-

Строка

Нет

Тип_клиента

Тип клиента

Перечисление.

Тип_клиента

Нет

Справочник №3 «Туристы»

Таблица 3.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Имя

-

Строка

Нет

Пол

-

Перечисление.Пол

Нет

Гражданство

-

Перечисление.

Гражданство

Нет

Дата_рожд

Дата рождения

Дата

Нет

Номер_З_паспорта

Номер паспорта

Число

Нет

Дата_окончания

Дата окончания

Дата

Нет

Виза

-

Строка

Нет

Адрес_прож

-

Строка

Нет

Тел_моб

-

Строка

Нет


Справочник №4 «Операторы»

Таблица 4.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Полное_наименование

-

Строка

Нет

Реестровый_номер

-

Строка

Нет

Почт_адрес

Почтовый адрес

Строка

Нет

Юр_адрес

Юр.адрес

Строка

Нет

Тел

Тел.

Строка

Нет

Факс

Факс

Строка

Нет

ИНН_КПП

ИНН/КПП

Строка

Нет

РС

р/сч

Строка

Нет

Наим_Б

Банк

Строка

Нет

БИК

-

Число

Нет

КС

к/с

Строка

Нет

Отв_лицо

Ответственное лицо

Строка

В диалоге

Нет

ФинОб

Размер финансового обеспечения

Число

Нет

ном_дог_страх

Номер договора страхования

Строка

Нет

дог_страх_от

дата от

Дата

Нет

дог_страх_до

дата до

Дата

Нет

Наимен_орг_страх_полн

Наименование организации, предоставившей фин.обеспечение

Строка

В диалоге

Нет

Наимен_орг

наименование организации

Строка

Нет

Юр_почт_адрес

Юридический и почтовый адрес

Строка

Нет

Место_нахожд

Место нахождения

Строка

Нет

Справочник №5 «Отели»

Таблица 5.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Категория

-

Перечисление.

Категория_отеля

Нет

Адрес

-

Строка

Нет

Справочник №6 «Туры»

Таблица 6.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Страна

-

Справочник.Страны

Нет

Город

-

Строка

Нет

Адрес

-

Строка

Нет

Отель

-

Справочник. Отели

Нет

Справочник №7 «Страны»

Таблица 7.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Справочник №8 «Сотрудники»

Таблица 8.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Должность

-

Строка

Нет

Телефон

-

Строка

Нет

Справочник №9 «Аэропорты»

Таблица 9.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да

Аэропорты

-

Строка

Нет

Добраться

-

Строка

Нет

Справочник №10 «Авиакомпании»

Таблица 10.

Идентификатор

Синоним

Тип значения

Ред-ние

Обязательное поле

Код

-

Число

В диалоге

Да

Наименование

-

Строка

Да


Программа имеет следующие документы:

Документ «Договор»

Этот документ предназначен для оформления договора-поручения с клиентом, который может быть как юридическим, так и физическим лицом, а также для автоматического формирования всех приложений к договору. Для формирования документа необходимо заполнить все поля документа, из которых берутся данные для заполнения печатных форм документа.

Для начала необходимо выбрать тип клиента. В зависимости от выбранного типа клиента на форме документа появятся поля для заполнения ФИО клиента или же наименования организации, с которой агентство заключает договор. Дальше необходимо выбрать период, на который оформляется путешествие. После чего нужно выбрать Курорт из имеющегося перечня курортов, предоставляемых турагенством. Далее, заполняется остальная информация, необходимая для формирования дополнительных приложений к договору.

Этот документ также содержит кнопки «Ок», «Закрыть», «Печать договора», «Печать акта», «Страхование от невыезда»,  «Путевка (Л-1)», «Путевка (Л-2)», «Памятка» и  «Заявка на бронирование тура».

Рис.1 Выбран режим для заполнения данных о Физ. Лицах, а также информация о туре.

Рис.2 Режим для Юридических лиц и заполнения данных о туроператоре изменяет внешний вид формы.

По кнопке «Печать договора» формируется «Договор-ПОРУЧЕНИЕ», который содержит большинство данных с формы.

При нажатии на кнопку  «Печать акта» формируется «Акт об оказании услуг», который является Приложением №1 к текущему договору. По кнопке «Страхование от невыезда» формируется «Приложение №2» к договору. По кнопке «Путевка(Л-1)» формируется «Приложение к путевке», лист первый, где указываются данные туриста и выбранного им курорта. При нажатии на кнопку  «Путевка(Л-2)» формируется «Приложение к путевке», лист второй, с отрывным талоном и информацией, расшифровывающей сокращения в турпутевке.

При нажатии на кнопку «Памятка» выводится на печать памятка для клиентов о высокопатогенном гриппе.  

При нажатии на кнопку «Заявка на бронирование тура», формируется «Заявка», которая отправляется туроператору после оформления всей документации с клиентом.

Пример печатных форм приводится в пункте V. «Приложение» на стр. 49 (Приложение 1).


Документ «Акт выполненных работ».

Документ представляет собой Акт выполненных работ, который формируется на основе уже заключенного договора. В данном документе требуется ввести только номер акта, а также номер договора.

Рис 3. Внешний вид формы Акта выполненных работ.

Этот документ также содержит кнопки «Ок», «Закрыть» и «Печать». При нажатии на кнопку «Печать», формируется печатная форма. Пример печатной формы приводится в пункте V. «Приложение» на стр. 69 (Приложение 2).


Программа имеет следующие отчеты:

Отчет «Статистика по направлениям»

Рис 4. Внешний вид формы отчета.

Данный отчет показывает общее количество заключенных договоров по направлениям за  указанный период, то есть, сколько за определенный период и по каким направлениям было поездок.

Пользователь может выбрать период, за который нужно сформировать отчет. Пример печатной формы приводится в пункте V. «Приложение» на стр. 72 (Приложение 3).


Отчет «Отчет по клиентам»

Рис 5. Внешний вид формы отчета.

Данный отчет позволяет определить, на какую общую сумму какой клиент заключал договоры за определенный период, кроме того, отбор также ведется по типам клиентов. Можно выбрать формирование отчета либо по физическим, либо по юридическим лицам. Пример печатной формы приводится в пункте V. «Приложение» на стр. 74 (Приложение 3)


Отчет «Информация о путешествиях»

Рис 6. Внешний вид формы отчета.

Данный отчет показывает заключенные договоры, а также направления  за  указанный период.

Пользователь может выбрать период, за который нужно сформировать отчет, а также может ограничить выборку конкретным типом клиента и ФИО клиента или наименованием организации, и  можно сформировать детализированный отчет. Пример печатной формы приводится в пункте V. «Приложение» на стр. 76 (Приложение 3).


4.1.2 Структурная схема

Схема 2. Структурная схема конфигурации.

 


4.2. Программирование.

В соответствии со структурно схемой, приведенной выше в пункте «Структурная схема», в представленной программе разработаны тексты программных модулей на встроенном языке «1C:Предприятие 7.7». Тексы, соответствующие программе и запросам, приведены в пункте V. «Приложение».


4.3 Аномалии и защищенное программирование

Таблица 11.

Описание аномалии

Реакции на аномалию

Способ защиты

Попытка ввести дату меньше текущей.

Дата автоматически исправляется на текущую дату.

Защищено разработчиком

Попытка ввести в числовое поле текстовые значения.

Нет возможности ввести благодаря использованию маски ввода.

Защищено разработчиком

Не выбраны какие-либо значения, либо оставлены пустые поля.

При попытке напечатать или провести документ, система выдает ошибку с указанием незаполненных полей.

Защищено разработчиком

С целью повышения надежности функциональности программы необходимо обеспечить контроль:

Ввода корректных данных дат, конечная дата должна быть больше начальной, иначе выводиться сообщение об ошибке;

Невозможность записи данных в справочнике, если не записаны некоторые необходимые данные в окна ввода информации;

Невозможность проведения документа, если не введены или не выбраны некоторые необходимые параметр или наименования.


4.4.
 Тестирование и отладка.

Тестирование – процесс многократного выполнения программы с целью выявления ошибок. Отладка – исправление ошибок, найденных с помощью тестирования. При тестировании должны использоваться следующие принципы:

  1.  Необходимой частью каждого теста должно являться описание ожидаемых результатов работы программы, чтобы можно было быстро выяснить наличие или отсутствие ошибки в ней;
  2.  Т.к. присутствует тот фактор, что обнаружение недостатков в своей деятельности противоречит человеческой психологии и по многим другим факторам, тестирование должно производить посторонний человек  или организация;
  3.  Должны являться правилом досконального изучение результатов каждого теста, чтобы не пропустить малозаметную на поверхностный взгляд ошибку в программе;
  4.  Необходимо тщательно подбирать тест не только для правильных  (предусмотренных) входных данных, но и для  неправильных (непредусмотренных);
  5.  При анализе результатов каждого теста необходимо проверить, не делает ли программу того, что она не должна делать;
  6.  Следует сохранять использованные тесты (для повышения эффективности повторного тестирования программы после ее модификации или установки у заказчика);
  7.  Следует учитывать так называемый «принцип скопления ошибок»: вероятность наличия не обнаруженных ошибок в некоторой части программы прямо пропорциональна числу ошибок, уже обнаруженных в этой части;

Хотя программа прошла тестирование успешно, в ней, тем не менее, могут содержаться ошибки, т.к.

  1.  программа может не соответствовать своей внешней спецификации, что в частности, может привести к тому, что в ее  управляющей графе окажутся пропущенными некоторые необходимые пути;

2) не будут обнаружены ошибки, появление которых зависит от обрабатываемых данных (т.е. на одних исходных данных программа работает правильно, а на других – с ошибкой).


5. Анализ результатов решения

В соответствии с пунктом 4.4 тестирование и отладка производились непосредственно во время разработки проекта. После завершения работы над конфигурацией было еще раз произведено полное тестирование всей программы. Все найденные ошибки были успешно устранены.

Получившаяся в результате конфигурация удовлетворяет всем предъявленным требованиям, полностью работоспособна, не требует принципиальных доработок, и готов к эксплуатации.


6. Инструкция пользователю

Общие сведения о программе «Автоматизация учета клиентов туристического агентства».

Данное программное приложение разработано для более эффективной и быстрой работы с информацией о клиентах, обработке туристической документации, а так же для автоматического формирования всех необходимых для заключения договора с клиентом документов.

Программа позволяет:

  •  Вводить и хранить данные о клиентах и заключенных с ними договоров.
  •  На основании введенных данных от клиента автоматически формировать договор, приложения и другие документы для упрощенного оформления всего пакета документов для путешествия.
  •  Осуществлять автоматизированный отбор нужной информации.
  •  Формировать и выводить на печать документы для оформления и отчетные формы.

Достоинства программы «Автоматизация учета клиентов туристического агентства»:

  •  удобство и простота в эксплуатации;
  •   небольшой объём занимаемой памяти на HDD;
  •  оперативное обслуживание клиентов.

Запуск программы.

Запуск программы осуществляется двойным нажатием левой клавиши мыши на ярлыке программы «1С: Предприятие 7.7», далее необходимо выбрать конфигурацию «Турагенство «Отпуск»» и нажать кнопку «ОК».

Рис 7. Запуск программы «1С:Предприятие».

Далее появиться окно авторизации доступа, в нем необходимо выбрать пользователя.

Рис 8. Окно входа в программу «1С:Предприятие». Ввод имени пользователя и пароля.

После запуска программного модуля в системе «1С: Предприятие 7.7»   на экране появится «Рабочее окно системы 1С: Предприятие 7.7», в нем

отображается меню и панель инструментов в соответствии с выбранным пользователем, оно выглядит следующим образом:

Рис. 9 Внешний вид меню конфигурации.

Работа с меню

Данное меню можно разделить на стандартное:

  •  меню «Файл»;
  •  меню «Операции»;
  •  меню «Сервис»;
  •  меню «Окна»;
  •  меню «Помощь»,

и индивидуальное, созданное разработчиком в соответствии с задачами конкретного пользователя, рассмотрим его подробнее на примере пользователя «Менеджер»:

  •  меню «Справочники»;

Рис. 10 Внешний вид меню Справочники.

ФизЛица открывает Справочник «ФизЛица», который также  открывается при нажатии на кнопку  ФизЛица на панели инструментов. В списке представлены наименования клиентов - физических лиц, а также их контактная информация. Редактирование и ввод нового клиента производиться в форме диалога.

ЮрЛица открывает Справочник «ЮрЛица», который также  открывается   при нажатии на кнопку ЮрЛица на панели инструментов. В списке представлены наименования клиентов - юридических лиц, а также их контактная информация и реквизиты. Редактирование и ввод нового клиента производиться в форме диалога

Туристы открывает Справочник «Туристы», который также  открывается при нажатии на кнопку "Туристы" на панели инструментов. В списке представлены наименования туристов, а также их контактная информация. Редактирование и ввод нового туриста производиться в форме диалога.

Операторы открывает Справочник «Операторы», который также  открывается  при нажатии на кнопку "Операторы" на панели инструментов. В списке представлены наименования туроператоров, с которым работает или работало турагенство, а также их контактная информация и реквизиты. Редактирование и ввод нового оператора производиться в форме диалога.

Отели открывает Справочник «Отели», является вспомогательным справочником к справочнику «Туры», который также открывается  при нажатии на кнопку "Отели" на панели инструментов. В списке представлены наименования отелей, а также информация об адресе и количестве "звезд". Редактирование и ввод нового отеля производиться в форме диалога.

Туры открывает Справочник «Туры», который также открывается  при нажатии на кнопку «Туры» на панели инструментов.

В списке представлены наименования туров, а также информация об отеле, стране и городе тура. Редактирование и ввод нового тура производиться в форме диалога.

Страны открывает Справочник «Страны», который также открывается    при нажатии на кнопку «Страны» на панели инструментов. В списке представлено  большинство наименований стран, в которые возможны туры. Редактирование и ввод нового значения производиться в форме списка.

Сотрудники открывает Справочник «Сотрудники», который также открывается при нажатии на кнопку "Сотрудники" на панели инструментов. В списке представлены наименования сотрудников турагенства, а также их должность и контактная информация. Редактирование и ввод нового сотрудника производиться в форме диалога.

Аэропорты открывает Справочник «Аэропорты», который также открывается  при нажатии на кнопку «Аэропорты» на панели инструментов. В списке представлены наименования аэропортов, а также их описание и информация о том, как до него добраться. Редактирование и ввод нового туриста производиться в форме диалога. Есть возможность вывести информацию из данного справочника на печать. Для этого нужно выбрать позицию и нажать «Печать».

Авиакомпании открывает Справочник «Авиакомпании», который также открывается  при нажатии на кнопку «Авиакомпании» на панели инструментов. В списке представлены наименования авиакомпаний, совершающих чартерные авиарейсы по странам мира, а также компании, которые имеют лицензию на перевозку пассажиров по туристическим направлениям. Редактирование и ввод новой авиакомпании производиться в форме списка.

  •  меню «Документы»;

Рис. 11 Внешний вид меню Документы.

Акт – создает новый документ «Акт выполненных работ».

Договор – создает новый документ «Договор – поручении».

  •  меню «Журналы»;

Рис. 12 Внешний вид меню Журналы.

Акты – открывает журнал «Акты», в котором содержаться все документы, сформированные за определенный период.

Договоры– открывает журнал «Договоры», в котором содержаться все договоры, производящие движения денежных средств, созданные за определенный период.

Общий – открывает журнал «Общий», в котором содержаться все документы созданные за определенный период.

  •  меню «Отчеты».

Рис. 13 Внешний вид меню Отчеты.

Статистика по направлениям - открывает форму отчета, для выбора параметров.

Суммы заключенных договоров - открывает форму отчета, для выбора параметров.

Информация о путешествии - открывает форму отчета, для выбора параметров.

Справка программы находиться в стандартном меню «Помощь», в пункте «Общее описание». В ней вы узнаете общие сведения о программе, предназначение и рекомендации по работе с документами и отчетами.

Рис. 14 Внешний вид справки конфигурации.
II
. Экономическая часть.

Экономический эффект от реализации и внедрения программного продукта.

Для того чтобы доказать необходимость внедрения конфигурации «Автоматизация учета клиентов туристического агентства», необходимо посчитать экономический эффект от его внедрения.

Экономический эффект состоит в сокращении временных затрат сотрудника на ввод данных. Прежде всего, это экономия денежных средств предприятия, которая может быть достигнута за счет:

  •  сокращения времени на качественный и удобный  учет лекарств;
  •  снижение времени на обработку данных;

1. Расчет затрат на разработку.

I. Разработка

Распределение трудоемкости по стадиям разработки приведено в  таблице 12.

Таблица 12.

Этап разработки

Содержание работ

Трудоемкость ч.

Постановка задачи

Предпроектное обследование.

Разработка, согласование и утверждение технико-экономического обоснования.

10

Технический проект

Уточнение структуры и формы представления входных и выходных данных. Разработка алгоритма решения задачи. Разработка структуры программы. Разработка плана мероприятий по разработке и внедрению ПП. Разработка пояснительной записки. Согласование и утверждение технического проекта.

67

Этап разработки

Содержание работ

Трудоемкость ч.

Рабочий проект

Описание программы на языке программирования. Разработка, согласование и утверждение порядка и методики испытаний, корректировка программы.

60

Документация и внедрение.

Разработка программной документации. Подготовка к сдаче программы и программной документации.

29

Итого:

166

II. Расчет коэффициента

1. Коэффициент сложности задачи c характеризует относительную сложность программы по отношению к так называемой типовой задаче, реализующей стандартные методы решения, сложность которой принята равной единице (величина c лежит в пределах от 0,5 до 1,5). Для программного продукта, включающего в себя алгоритмы ввода данных, сложность задачи берем 0,8 так как данный программный продукт уступает по сложности типовым решениям данной задачи, таким как «1С:Предприятие 7.7» Версия 7.7.

c = 0,8 – коэффициент сложности программы.

2. Коэффициент коррекции программы p – увеличение объема работ за счет внесения изменений в алгоритм или программу по результатам уточнения постановок. С учетом того, что в данном случае заказчик, представлял себе, что он хочет получить, что приводило к немногочисленным доработкам, возьмем коэффициент p = 0,3.

р = 0,3 – коэффициент коррекции программы в ходе разработки.

3. Коэффициент b увеличение затрат труда, вследствие недостаточного описания задачи, в зависимости от сложности задачи принимается от 1,2 до 1,5, в связи с тем, что данная задача, не потребовала уточнения и больших доработок, примем b = 1,3.

b = 1,3 - коэффициент увеличение затрат труда.

4. Коэффициент квалификации разработчика k определяется  в зависимости от стажа работы и составляет:

для работающих до 2 лет – 0,8;

от 3 до 5 лет – 1,0;

от 5 до 8 лет – 1,2;

свыше 8 лет – 1,5.

Разработчик, которому было поручено это задание, имел опыт работы по специальности менее двух лет, поэтому примем k = 0,8.

k = 0,8 - коэффициент квалификации разработчика.

III. Расчет затрат предприятия.

1. Оклад программиста составляет 6,000 рублей. В связи с коэффициентами заработной платы, основная заработная плата разработчика программного продукта составит:

ЗП осн = ЗП * с * (р + 1) * b * k = 6000* 0,8 * (0,3 + 1) * 1,3 * 0,8

ЗП осн = 6489,6 рублей.

2. Страховые отчисления берутся в размере 26% от основной заработной платы, и равны: 6489,6 *26% = 1687,30 руб.

Поскольку дополнительная заработная плата в виде премии работнику за это время не выплачивалась, то суммарная заработная плата (ЗП сум) за весь период разработки программного продукта составит:

ЗП Сум = (6489,6руб. +1687,30руб ) * 166 ч. = 7712,30

   176 ч.

(рублей за период разработки)

2. Содержание и эксплуатация вычислительной техники.

Амортизация.

Содержание и эксплуатация вычислительного комплекса считается следующим образом: Свт = См-ч * Число_часов_отладки,

где См-ч – стоимость машинного – часа.

Число часов отладки составляет:

Уточнение структуры и формы представления, входных и выходных данных, разработка алгоритма решения задачи, разработка структуры программы, разработка плана мероприятий по разработке и внедрению ПП, разработка пояснительной записки, согласование и утверждение технического проекта составили по времени 67 часа.

Описание программы на языке программирования, разработка, согласование и утверждение порядка и методики испытаний, корректировка программы составила 60 часов.

Разработка программной документации, подготовка к сдаче программы и программной документации составила 29 часов.

Итого число часов отладки составляет: 67 + 60 + 29= 156 часов.

Стоимость машинного – часа рассчитывается, как сумма составляющих:

(Ст-ть_эл_эн_в_год + Аморт_в_год + Затраты_на_ремонт_за_год) / Фвт

где Фвт – действительный фонд времени работы вычислительного комплекса.

1.Стоимость электроэнергии.

Стоимость 1кВт/час электроэнергии составляет: 3 руб.

Один компьютер потребляет 300 ВТ в час.

В год отчисления за электроэнергию, потребляемую одной ЭВМ, составляет:

С_эл_эн_в_год = 8 ч. * 22 дня * 12 мес. * 0,3 кВт/ч. * 3  руб. = 1900,8 руб.

2. Отчисления зависит от срока полезного использования компьютера, а так как срок эксплуатации компьютера, равный 3 годам, еще не истек, то необходимо исчислить амортизационные отчисления и учитывать их в дальнейших амортизационных отчислениях.

Расчет амортизационных отчислений:

Отчисления  = Стоимость ПК \ Срок полезного использования.

При стоимости ПК 24 000 и сроке полезного использования в 4 года при реальном сроке в 3 года, отчисления составят:

24000\4 = 6000 (1 год амортизации.)

Затраты на ремонт компьютера составляют 5% от его стоимости.

24 000 *5% = 1200 рублей в год.

Действительный фонд времени работы вычислительного комплекса рассчитываем по следующей формуле:

Фвт = Фном - Фпроф, где

Фном – номинальный фонд времени работы вычислительного комплекса,

Фпроф – годовые затраты времени на профилактические работы

(принимаются 5% от Фном).

Стоимость ремонта ЭВМ = 5% от стоимости ПК

Стоимость ремонта ЭВМ = 24 000* 5% = 1200 рублей в год.

Компьютер в  год работает 2 112 часов ( 22 дня в месяц * 12 месяцев в год *8 часов работы в день = Фном) при условии, что на

плановый ремонт уходит 5 % рабочего времени. Окончательное время

работы:

Фвт = Фном - Фпроф) = 2212 - 5% =  2 101 ч.

Рассчитаем стоимость машинного часа:

Стоимость машинного часа = С_эл_эн_в_год + 1 год амортизации + затраты на ремонт компьютера.

Стоимость машинного часа = (1900,8+6000+1200)/2101 = 4,5 руб.

Стоимость машинного часа составляет 4,5 руб.

Содержание и эксплуатация вычислительного комплекса составляет:

156ч. * 4,5 руб. = 702 руб при написании конфигурации.

Покупка нового компьютера не требуется, так как данная конфигурация будет работать и на старом компьютере, имеющемся в распоряжении организации.

Для работы моей конфигурации не потребовалось приобретать лицензионную версию «1С:Предприятие 7.7», так как она была приобретена и установлена в 2003 году, привлечение дополнительных так же не требуется.

Смета затрат на разработку данной конфигурации приведена в таблице 13.

Таблица 13.

Наименование статьи расходов

Затраты руб.

1

Основная заработная плата

6489,6

2

Страховые отчисления

1687,30

3

Содержание и эксплуатация вычислительного комплекса

702

4

Программное обеспечение

0

Итого:

8878,9


Экономический эффект.

Рассчитаем экономический эффект, получаемый за счет экономии рабочего времени менеджера. Благодаря этой экономии он сможет выполнить большее количество работ. В нашем случае это заключение договоров с клиентами.

Для ведения  расчетов введем следующее обозначения:

Т1 = время, затрачиваемое на операцию до внедрения конфигурации.

Т2 = время, затрачиваемое на эти работы после внедрения конфигурации.

Т = время, сэкономленное в результате внедрения конфигурации.

До внедрения конфигурации данные вводились вручную и  на то, чтобы качественно оформить документацию для клиента сотрудник в среднем в  день тратил около  1 ч на полное оформление документации одного клиента:

Т1 = 1 ч.

После внедрения конфигурации время сократится  до 25 минут или 0,25 ч. (за одну операцию) за счет автоматизации ввода и удобного, эргономичного интерфейса:

Т2= 25 минуты  или 0,25 ч.

  Усредненное количество операций ввода данных за день одним сотрудником офиса в среднем составляет 8 операций за день или 176 операций ввода данных в месяц (8 операций * 22 дня). Количество операций за год равна:

Х = 8 операций * 22 дня * 12 мес. = 2112 (опер.\год)

2112 операций * 1 ч. = 2112 час./ год,

тогда Т1 = 2112 час./ год – общее время за год, до внедрения программного приложения.

2112 операций * 0,25 ч. = 528 час./ год,

тогда Т2 = 528 час./ год – общее время за год, после внедрения программного приложения.

Разница в затрачиваемом на работу времени:

  Т = Т1 – Т2 = 2112 – 528 =  1584 час./ год – годовая экономия средств.

А теперь рассчитаем заработную плату сотрудника офиса, который обслуживает клиентов.

Основная заработная плата одного сотрудника офиса составляет 10 000 рублей  в месяц. Дополнительная заработная плата не выплачивается.

Страховые отчисления рассчитываются, как 26 % от основной заработной платы, что составляет: 10 000 руб. * 26 % = 2600 руб.

В общем, на одного сотрудника затрачивается:

10000+ 2600 = 12600 руб. (в месяц)

12600 руб. / (8 час.*22 дня) = 71, 5 руб. – стоимость одного часа работы сотрудника офиса.

Общий экономический эффект для туристического агентства составит:

1584 час.* 71,5 руб. = 113 256 руб. в год при внедрении

Итак, общий экономический эффект при внедрении конфигурации в туристическое агентство составит 113 256 руб. в год, при этом заметно сократится время сотрудников, что повысит продуктивность работы.

Срок окупаемости проекта  = затраты на внедрении программного приложения  / общий экономический эффект = 8878,9\113 256 руб = 0,08 (год) или 1 месяц.

Следовательно, если офис внедрит  конфигурацию «Автоматизация учета клиентов туристического агентства», то она окупится через 1 месяц.


III. Заключение

В изложенной дипломной работе на тему «Автоматизация учета клиентов туристического агентства» была реализована задача автоматизированного  учета  клиентов.

Разработанная конфигурация упростила процедуру оформления  необходимых документов.

Разработанная конфигурация полностью соответствует п. 1. «Постановка задачи».

Была произведена экономическая оценка эффективности от внедрения конфигурации, которая показала, что проект  экономически целесообразен и может быть одобрен на внедрение в туристическую организацию.

Срок окупаемости конфигурации 1 месяц.


V I. Литература.

  •  А. Михайлов, «1С.Предприятие 7.7/8.0. Системное программирование», 2-ое издание, Изд-во фирмы БХВ-Петербург, 2007 г.
  •  http://www.mista.ru/
  •  Дехтярь Г.М. «Лицензирование и сертификация в туризме», Изд-во фирмы Финансы и статистика, 2007 г.
  •  Бабкин А.В. «Специальные виды туризма», Изд-во фирмы Ростов-на-Дону: Феникс, 2008 г.


V. Приложение.

Документы.

Документ «Договор».

Приложение 1.

Код модуля формы:

Процедура ПриОткрытии()

  1.  //регулировка начального отображения слоев
  2.  ПриЗаписиПерепроводить(1);
  3.  Тип = Перечисление.Тип_клиента.Физ_лицо;
  4.  Невыезд = Перечисление.Невыезд.Да;
  5.  Форма.ИспользоватьСлой("Основной",1);
  6.  Если Тип = Перечисление.Тип_Клиента.Физ_лицо тогда
  7.  Форма.ИспользоватьСлой("Физ_Лица",1);
  8.  Форма.ИспользоватьСлой("Тур",1);
  9.  Форма.ИспользоватьСлой("Тур_оператор",0);
  10.   Форма.ИспользоватьСлой("Юр_лица",0);
  11.   Форма.ИспользоватьСлой("Таблица",0);
  12.   Форма.кн_тур.Видимость(0);
  13.   Иначе
  14.   Форма.ИспользоватьСлой("Физ_Лица",0);
  15.   Форма.ИспользоватьСлой("Тур",1);
  16.   Форма.ИспользоватьСлой("Тур_оператор",0);
  17.   Форма.ИспользоватьСлой("Юр_лица",1);
  18.   Форма.ИспользоватьСлой("Таблица",0);
  19.   Форма.кн_тур.Видимость(0);
  20.   КонецЕсли;
  21.   КонецПроцедуры     
  22.   Процедура Переключать()
  23.   //переключатель слоя в зависимости от типа клиента
  24.   Если Тип = Перечисление.Тип_Клиента.Физ_лицо Тогда
  25.   Форма.ИспользоватьСлой("Физ_Лица",1);
  26.   Форма.ИспользоватьСлой("Юр_лица",0);
  27.   Иначе  Тип = Перечисление.Тип_Клиента.Юр_лицо;
  28.   Форма .ИспользоватьСлой("Юр_лица",1);
  29.   Форма. ИспользоватьСлой("Физ_Лица",0);
  30.    КонецЕсли;         
  31.    КонецПроцедуры
  32.    Процедура АвтоЗапКлиент()
  33.   / /Автозаполнение данных о клиенте
  34.   Паспорт_клиента = Наименование_Клиента.Паспорт;
  35.   Паспорт_выдан_кем = Наименование_Клиента.П_Выдан;
  36.   П_выдан_когда = Наименование_Клиента.Дата_выдачи;
  37.   Адрес_клиента = Наименование_Клиента.Адрес;
  38.   Тел_клиента = Наименование_Клиента.Дом_телефон + " " +  Наименование_Клиента.Моб_телефон;
  39.   КонецПроцедуры
  40.   Процедура АвтоЗапЮр()
  41.   //Автозаполнение данных о юр.лице
  42.   ФИО_рук = Юр_орг.ФИО_рук;
  43.   Юр_адрес = Юр_орг.Юр_адрес;
  44.   Юр_Факт_адрес = Юр_орг.Факт_адрес;
  45.   Юр_тел = Юр_орг.Тел;
  46.   Юр_факс = Юр_орг.Факс;
  47.   Юр_ИНН = Юр_орг.ИНН;
  48.   Юр_рс = Юр_орг.рс;
  49.   Юр_в_отд_банк = Юр_орг.в_отд_банк;
  50.   Юр_кс = Юр_орг.кс;
  51.   Юр_кс_в_банк = Юр_орг.кс_в_банк;
  52.   Юр_БИК = Юр_орг.БИК;
  53.   Юр_email= Юр_орг.email;
  54.   КонецПроцедуры      
  55.   Процедура АвтоЗапОператор()
  56.   //Автозаполнение данных о туроператоре
  57.   Полн_наимен_операт = Наим_туро.Полное_наименование;
  58.   Реестр_ном = Наим_туро.Реестровый_номер;
  59.   Место_нахожд = Наим_туро.Юр_адрес;
  60.   Размер_фин_об = Наим_туро.ФинОб;
  61.   Ном_дог_страх = Наим_туро.ном_дог_страх;
  62.   дог_страх_от = Наим_туро.дог_страх_от;
  63.   дог_страх_до = Наим_туро.дог_страх_до;
  64.   наимен_орг_страх_полн = Наим_туро.Наимен_орг_страх_полн;
  65.   Наимен_орг = Наим_туро.Наимен_орг;
  66.   Юр_почт_адрес = Наим_туро.Юр_почт_адрес;
  67.   Место_нахожд_страх_орг = Наим_туро.Место_нахожд;
  68.   КонецПроцедуры
  69.   Процедура ВидимСлои()
  70.   // процедура, позволяющая отображать слои
  71.   Форма.ИспользоватьСлой("Тур",0);
  72.   Форма.ИспользоватьСлой("Тур_оператор",1);
  73.   Форма.ИспользоватьСлой("Таблица",0);
  74.   Форма.кн_туроп.Видимость(0);
  75.   Форма.кн_тур.Видимость(1);
  76.   КонецПроцедуры

 

  1.   Процедура ВидимСлои1()
  2.   // процедура, позволяющая отображать слои
  3.   Форма.ИспользоватьСлой("Тур",1);
  4.   Форма.ИспользоватьСлой("Тур_оператор",0);
  5.   Если Налич_групп = Перечисление.Группа.Нет Тогда
  6.   Форма.ИспользоватьСлой("Таблица",0);
  7.   Иначе
  8.   Форма.ИспользоватьСлой("Таблица",1);
  9.   КонецЕсли;
  10.   Форма.кн_туроп.Видимость(1);
  11.   Форма.кн_тур.Видимость(0);
  12.   КонецПроцедуры
  13.   Процедура ВидимТ()
  14.   // процедура, позволяющая отображать таблицу
  15.   Если Налич_групп = Перечисление.Группа.Нет Тогда
  16.   Форма.ИспользоватьСлой("Таблица",0);
  17.   Иначе
  18.  Форма.ИспользоватьСлой("Таблица",1);
  19.   КонецЕсли
  20.   КонецПроцедуры
  21.   Процедура ВалидацияДат()
  22.   Если Прибытие > Отъезд Тогда
  23.   Отъезд = Прибытие;
  24.   ИначеЕсли Прибытие < ТекущаяДата() тогда
  25.  Прибытие = ТекущаяДата();
  26.  КонецЕсли
  27.  КонецПроцедуры
  28.  //Таблица автовыбор
  29.  Процедура АвтоТуристы()
  30.  Если Фамилия_групп <> "" тогда
  31.  Имя_групп = Фамилия_групп.Имя;
  32.  Пол = Фамилия_групп.Пол;
  33.  Гражданство = Фамилия_групп.Гражданство;
  34.  Дата_рожд_групп = Фамилия_групп.Дата_рожд;
  35.  Паспорт_групп = Фамилия_групп.Номер_З_паспорта;
  36.  Дата_оконч = Фамилия_групп.Дата_окончания;
  37.  Адрес_Т = Фамилия_групп.Адрес_прож;
  38.  Тел_Т = Фамилия_групп.Тел_моб;
  39.  Виза = Фамилия_групп.Виза;  
  40.  КонецЕсли;    
  41.  _Ном = 0;                    
  42.  паспорт=Паспорт_групп;
  43.  Выбратьстроки();
  44.  пока Получитьстроку()=1 цикл
  45.  если  Паспорт_групп=паспорт тогда  
  46.  Если _Ном > 0 Тогда     
  47.  Фамилия_групп="";
  48.  сообщить("Такой турист уже выбран! Выберите другое значение или удалите строку!");
  49.  Прервать;   
  50.  Ном = НомерСтроки;     
  51.  КонецЕсли;
  52.  _Ном = НомерСтроки;    
  53.  Конецесли;     
  54.  конеццикла;        
  55.  КонецПроцедуры
  56.  Процедура АвтоКурорт()
  57.  Страна = Курорт.Страна;
  58.  Город = Курорт.Город;
  59.  Отель = Курорт.Отель;
  60.  Категория = Отель.Категория;
  61.  КонецПроцедуры
  62.  Процедура Налич()
  63.  Если Тип = Перечисление.Тип_Клиента.Юр_лицо
  64.  тогда  
  65.  Налич_групп = Перечисление.Группа.Да;
  66.  форма.Налич_групп.Доступность(0);
  67.  Форма.ИспользоватьСлой("Таблица",1);
  68.  Иначе Форма.Налич_групп.Доступность(1);
  69.  КонецЕсли;
  70.  КонецПроцедуры
  71.  //Нет к дополнительным услугам:
  72.  Процедура НетДоп()
  73.  Если Ф_доп = 1
  74.  тогда доп = "нет";
  75.  Форма.Доп.Доступность(0);
  76.  иначе доп = "";
  77.  Форма.Доп.Доступность(1);
  78.  КонецЕсли
  79.  КонецПроцедуры
  80.  Процедура Аэропорт()
  81.  Прибытие_обр = Вылет_туда;
  82.  Вылет_обр = Прибытие_туда;
  83.  КонецПроцедуры
  84.  Процедура Печать()
  85.  Если Номер_дог = "   -  /   " тогда
  86.  сообщить("Введите номер договора! Печать невозможна.");
  87.  возврат;
  88.  конецесли;

  1.  Если Тип = Перечисление.Тип_клиента.Физ_лицо тогда
  2.  Если Наименование_Клиента.выбран()=0 тогда
  3.  сообщить("Выберите клиента! Печать невозможна.");
  4.  возврат;
  5.  конецесли;
  6.  ИначеЕсли Тип = Перечисление.Тип_клиента.Юр_лицо тогда
  7.  Если Юр_орг.выбран()=0 тогда
  8.  сообщить("Выберите клиента! Печать невозможна.");
  9.  возврат;
  10.  конецесли;
  11.  Конецесли;
  12.  Если Цена_договора=0 тогда
  13.  сообщить("Не указана цена договора! Печать невозможна.");
  14.  возврат;
  15.  конецесли;
  16.  Если Наим_туро.выбран()=0 тогда
  17.  сообщить("Выберите туроператора! Печать невозможна.");
  18.  возврат;
  19.  конецесли;
  20.  Если курорт.выбран()=0 тогда
  21.  сообщить("Выберите куророт! Печать невозможна.");
  22.  возврат;
  23.  конецесли;
  24.  Если Пансион.выбран()=0 тогда
  25.  сообщить("Выберите пансион! Печать невозможна.");
  26.  возврат;
  27.  конецесли;  
  28.  Если Номер.выбран()=0 тогда
  29.  сообщить("Выберите номер! Печать невозможна.");
  30.  возврат;
  31.  конецесли;
  32.  Если Мед_Страх.выбран()=0 тогда
  33.  сообщить("Выберите значение Мед.страх! Печать невозможна.");
  34.  возврат;
  35.  конецесли;
  36.  Если ПустоеЗначение(Прибытие)=1 тогда
  37.  сообщить("Введите дату прибытия! Печать невозможна.");
  38.  возврат;
  39.  конецесли;
  40.  Если ПустоеЗначение(Отъезд)=1 тогда
  41.  сообщить("Введите дату отъезда! Печать невозможна.");
  42.  возврат;
  43.  конецесли;
  44.  Если Самолет_туда.выбран()=0 тогда

  1.  сообщить("Выберите вид самолета! Печать невозможна.");
  2.  возврат;
  3.  конецесли;   
  4.  Если Самолет_обр.выбран()=0 тогда
  5.  сообщить("Выберите вид самолета! Печать невозможна.");
  6.  возврат;
  7.  конецесли;
  8.  Если Вылет_туда.выбран()=0 тогда
  9.  сообщить("Выберите аэропорт вылета! Печать невозможна.");
  10.  возврат;
  11.  конецесли;  
  12.  Если ПустоеЗначение(Прибытие_туда)=1 тогда
  13.  сообщить("Выберите значение Мед.страх! Печать невозможна.");
  14.  возврат;
  15.  конецесли;
  16.  Если ПустоеЗначение(Рейс_туда)=1 тогда  
  17.  сообщить("Введите номер рейса! Печать невозможна.");
  18.  возврат;
  19.  конецесли;
  20.  Если ПустоеЗначение(Рейс_обр)=1 тогда
  21.  сообщить("Введите номер рейса! Печать невозможна.");
  22.  возврат;
  23.  конецесли;
  24.  Если Пустоезначение(Экс)=1 тогда
  25.  сообщить("Введите значение в поле Дополнительные экскурсии или поставьте нет! Печать невозможна.");
  26.  возврат;
  27.  конецесли;
  28.  Таб = СоздатьОбъект("Таблица"); //создаем таблицу в "" название таблице

  1.  Если  Тип = Перечисление.Тип_Клиента.Физ_лицо тогда    //если стоит галочка, то выводится накл№1"Таблица" иначе накл№2"Таблица1"
  2.  Таб.ИсходнаяТаблица("Таблица");    
  3.  иначе
  4.  Таб.ИсходнаяТаблица("Таблица1"); //к юр-лицу
  5.  КонецЕсли;
  6.  Пропись("");
  7.  ДатаПрописью = Формат(ДатаДок,"Д (0)ДДММММГГГГ");
  8.  Таб.ВывестиСекцию("Шапка");

  1.  Если Налич_групп = Перечисление.Группа.Да Тогда
  2.  п =0;   
  3.  Таб.ВывестиСекцию("Группа_Ш");
  4.  ВыбратьСтроки();
  5.  Пока ПолучитьСтроку()=1 цикл
  6.  п = п + 1;            
  7.  Таб.ВывестиСекцию("Группа");
  8.  Конеццикла;
  9.  КонецЕсли;
  10.  РазмПрописью  = Формат(Размер_фин_об,"ЧПДС");
  11.  Цена_договора = Цена_договора;
  12.  СумПроп  = Формат(Цена_договора,"ЧПДС");
  13.  Прибытие2=Прибытие - 7;
  14.  Таб.ВывестиСекцию("Подвал");
  15.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  16.  Таб.ТолькоПросмотр(1);
  17.  Таб.Показать("Печать договора","");
  18.  КонецПроцедуры
  19.  Процедура ПечатьАкта()
  20.  Если Номер_дог = "   -  /   " тогда
  21.  сообщить("Введите номер договора! Печать невозможна.");
  22.  возврат;
  23.  конецесли;
  24.  Если Тип = Перечисление.Тип_клиента.Физ_лицо тогда
  25.  Если Наименование_Клиента.выбран()=0 тогда
  26.  сообщить("Выберите клиента! Печать невозможна.");
  27.  возврат;
  28.  конецесли;
  29.  ИначеЕсли Тип = Перечисление.Тип_клиента.Юр_лицо тогда
  30.  Если Юр_орг.выбран()=0 тогда
  31.  сообщить("Выберите клиента! Печать невозможна.");
  32.  возврат;
  33.  конецесли;
  34.  Конецесли;
  35.  Таб = СоздатьОбъект("Таблица"); //создаем таблицу в "" название таблице
  36.  Если  Тип = Перечисление.Тип_Клиента.Физ_лицо тогда
  37.  Таб.ИсходнаяТаблица("АктФиз");    
  38.  иначе
  39.  Таб.ИсходнаяТаблица("АктЮр"); //к юр-лицу
  40.  КонецЕсли;
  41.  Пропись("");
  42.  ДатаПрописью = Формат(ДатаДок,"Д (0)ДДММММГГГГ");

  1.  Таб.ВывестиСекцию("Акт");
  2.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  3.  Таб.ТолькоПросмотр(1);
  4.  Таб.Показать("Печать приложения № 1","");
  5.  КонецПроцедуры
  6.  Процедура ПечатьСтрах()          
  7.  Если (Номер_дог = "   -  /   ") или (Номер_дог = "          ") тогда
  8.  сообщить("Введите номер договора! Печать невозможна.");
  9.  возврат;
  10.  конецесли;
  11.  Если Тип = Перечисление.Тип_клиента.Физ_лицо тогда                 
  12.  Если Наименование_Клиента.выбран()=0 тогда
  13.  сообщить("Выберите клиента! Печать невозможна.");
  14.  возврат;
  15.  конецесли;
  16.  ИначеЕсли Тип = Перечисление.Тип_клиента.Юр_лицо тогда           
  17.  Если Юр_орг.выбран()=0 тогда
  18.  сообщить("Выберите клиента! Печать невозможна.");
  19.  возврат;
  20.  конецесли;
  21.  КонецЕсли;
  22.  Если Невыезд.выбран()=0 тогда
  23.  сообщить("Выберите значение Страхование от невыезда! Печать невозможна.");    
  24.  возврат;
  25.  конецесли;  
  26.  Таб = СоздатьОбъект("Таблица");
  27.  Таб.ИсходнаяТаблица("Страхование");
  28.  Пропись("");
  29.  ДатаПрописью = Формат(ДатаДок,"Д (0)ДДММММГГГГ");
  30.  Таб.ВывестиСекцию("Шапка");
  31.  Если Тип = Перечисление.Тип_Клиента.Физ_лицо тогда
  32.  Таб.ВывестиСекцию("Физ");
  33.  Иначе Тип = Перечисление.Тип_Клиента.Юр_лицо;
  34.  Таб.ВывестиСекцию("Юр");
  35.  КонецЕсли;
  36.  Таб.ВывестиСекцию("Текст");
  37.  Если Невыезд = Перечисление.Невыезд.Да тогда
  38.  Таб.ВывестиСекцию("СДа");
  39.  Иначе Невыезд = Перечисление.Невыезд.Нет;
  40.  Таб.ВывестиСекцию("СНет");
  41.  КонецЕсли;
  42.  Если Тип = Перечисление.Тип_Клиента.Физ_лицо тогда
  43.  Таб.ВывестиСекцию("ПФиз");

  1.  Иначе Тип = Перечисление.Тип_Клиента.Юр_лицо;
  2.  Таб.ВывестиСекцию("ПЮр");
  3.  КонецЕсли;
  4.  Пропись("");
  5.  ДатаПрописью = Формат(ДатаДок,"Д (0)ДДММММГГГГ");
  6.  Таб.ВывестиСекцию("Дата");
  7.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  8.  Таб.ТолькоПросмотр(1);
  9.  Таб.Показать("Печать приложения № 2","");
  10.  КонецПроцедуры    
  11.  Процедура ПечатьПутевки1()
  12.  Если Серия = "   №           " тогда
  13.  сообщить("Введите серию и номер путевки! Печать невозможна.");
  14.  возврат;
  15.  конецесли;
  16.  Если Тип = Перечисление.Тип_клиента.Физ_лицо тогда
  17.  Если Наименование_Клиента.выбран()=0 тогда
  18.  сообщить("Выберите клиента! Печать невозможна.");
  19.  возврат;
  20.  конецесли;
  21.  ИначеЕсли Тип = Перечисление.Тип_клиента.Юр_лицо тогда
  22.  Если Юр_орг.выбран()=0 тогда
  23.  сообщить("Выберите клиента! Печать невозможна.");
  24.  возврат;
  25.  конецесли;
  26.  Конецесли;
  27.  Если Наим_туро.выбран()=0 тогда
  28.  сообщить("Выберите туроператора! Печать невозможна.");
  29.  возврат;
  30.  конецесли;
  31.  Если курорт.выбран()=0 тогда
  32.  сообщить("Выберите куророт! Печать невозможна.");
  33.  возврат;
  34.  конецесли;
  35.  Если Пансион.выбран()=0 тогда
  36.  сообщить("Выберите пансион! Печать невозможна.");
  37.  возврат;
  38.  конецесли;  
  39.  Если Номер.выбран()=0 тогда
  40.  сообщить("Выберите номер! Печать невозможна.");
  41.  возврат;
  42.  конецесли;
  43.  Если Мед_Страх.выбран()=0 тогда
  44.  сообщить("Выберите значение Мед.страх! Печать невозможна.");

  1.  возврат;
  2.  конецесли;
  3.  Если ПустоеЗначение(Прибытие)=1 тогда
  4.  сообщить("Введите дату прибытия! Печать невозможна.");
  5.  возврат;
  6.  конецесли;
  7.  Если ПустоеЗначение(Отъезд)=1 тогда
  8.  сообщить("Введите дату отъезда! Печать невозможна.");
  9.  возврат;
  10.  конецесли;
  11.  Если Самолет_туда.выбран()=0 тогда
  12.  сообщить("Выберите вид самолета! Печать невозможна.");
  13.  возврат;
  14.  конецесли;   
  15.  Если Самолет_обр.выбран()=0 тогда
  16.  сообщить("Выберите вид самолета! Печать невозможна.");
  17.  возврат;
  18.  конецесли;
  19.  Если Вылет_туда.выбран()=0 тогда
  20.  сообщить("Выберите аэропорт вылета! Печать невозможна.");
  21.  возврат;
  22.  конецесли;  
  23.  Если ПустоеЗначение(Прибытие_туда)=1 тогда
  24.  сообщить("Выберите значение Мед.страх! Печать невозможна.");
  25.  возврат;
  26.  конецесли;
  27.  Если ПустоеЗначение(Рейс_туда)=1 тогда  
  28.  сообщить("Введите номер рейса! Печать невозможна.");
  29.  возврат;
  30.  конецесли;
  31.  Если ПустоеЗначение(Рейс_обр)=1 тогда
  32.  сообщить("Введите номер рейса! Печать невозможна.");
  33.  возврат;
  34.  конецесли;
  35.  Если Рук_группы.выбран()=0 тогда
  36.  сообщить("Выберите значение: Наличие руководителя группы! Печать невозможна.");
  37.  возврат;
  38.  конецесли;
  39.  Если Леч.выбран()=0 тогда
  40.  сообщить("Выберите значение: наличие лечения! Печать невозможна.");
  41.  возврат;
  42.  конецесли;

  1.  Если Пустоезначение(Экс)=1 тогда
  2.  сообщить("Введите значение в поле Дополнительные экскурсии или поставьте нет! Печать невозможна.");
  3.  возврат;
  4.  конецесли;
  5.  Если Пустоезначение(Доп)=1 тогда
  6.  сообщить("Выберите значение: Дополнительные оплаченные услуги или поставьте нет ! Печать невозможна.");
  7.  возврат;
  8.  конецесли;
  9.  Таб = СоздатьОбъект("Таблица");
  10.  Таб.ИсходнаяТаблица("ПутевкаЛ1");
  11.  Таб.ВывестиСекцию("Шапка");
  12.  Если Тип = Перечисление.Тип_Клиента.Физ_лицо тогда
  13.  Таб.ВывестиСекцию("Физ");
  14.  Иначе Тип = Перечисление.Тип_Клиента.Юр_лицо;
  15.  Таб.ВывестиСекцию("Юр");
  16.  КонецЕсли;
  17.  Если Налич_групп = Перечисление.Группа.Да Тогда
  18.  Таб.ВывестиСекцию("Туристы");
  19.  ВыбратьСтроки();
  20.  п=0;
  21.  Пока ПолучитьСтроку()=1 цикл
  22.  п = п + 1;
  23.  Таб.ВывестиСекцию("Строка");
  24.  Конеццикла;
  25.  КонецЕсли;
  26.  Пропись("");
  27.  ДатаПрописью = Формат(ДатаДок,"Д (0)ДДММММГГГГ");
  28.  Таб.ВывестиСекцию("Низ");
  29.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  30.  Таб.ТолькоПросмотр(1);
  31.  Таб.Показать("Печать листа путевки № 1","");
  32.  КонецПроцедуры
  33.  Процедура ЭНет()
  34.  Если Э_н = 1
  35.  тогда экс = "нет"
  36.  Форма.экс.Доступность(0);
  37.  иначе
  38.  экс = "";
  39.  Форма.экс.Доступность(1);
  40.  КонецЕсли;
  41.  КонецПроцедуры   
  42.  Процедура ПечатьПутевки2()

  1.  Если Номер_дог = "   -  /   " тогда
  2.  сообщить("Введите номер договора! Печать невозможна.");
  3.  возврат;
  4.  конецесли;
  5.  Таб = СоздатьОбъект("Таблица");
  6.  Таб.ИсходнаяТаблица("ПутевкаЛ2");
  7.  Пропись("");
  8.  ДатаПрописью = Формат(ДатаДок,"Д (0)ДДММММГГГГ");
  9.  Таб.ВывестиСекцию("Путевка");
  10.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  11.  Таб.ТолькоПросмотр(1);
  12.  Таб.Показать("Печать листа путевки № 2","");
  13.  КонецПроцедуры     
  14.  Процедура ПечатьПамятки()
  15.  Таб = СоздатьОбъект("Таблица");
  16.  Таб.ИсходнаяТаблица("Памятка");
  17.  Таб.ВывестиСекцию("Памятка");
  18.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  19.  Таб.ТолькоПросмотр(1);
  20.  Таб.Показать("Печать памятки","");
  21.  КонецПроцедуры
  22.  Процедура ЗапСотр()
  23.  Должность = ФИО_сотр.Должность;
  24.  Тел_сотр = ФИО_сотр.Телефон;
  25.  КонецПроцедуры
  26.  Процедура ПечатьЗаявки()
  27.  Если Тип = Перечисление.Тип_клиента.Физ_лицо тогда
  28.  Если Наименование_Клиента.выбран()=0 тогда
  29.  сообщить("Выберите клиента! Печать невозможна.");
  30.  возврат;
  31.  конецесли;
  32.  ИначеЕсли Тип = Перечисление.Тип_клиента.Юр_лицо тогда
  33.  Если Юр_орг.выбран()=0 тогда
  34.  сообщить("Выберите клиента! Печать невозможна.");
  35.  возврат;
  36.  конецесли;
  37.  Конецесли;
  38.  Если Пансион.выбран()=0 тогда
  39.  сообщить("Выберите пансион! Печать невозможна.");
  40.  возврат;
  41.  конецесли;  
  42.  Если Номер.выбран()=0 тогда
  43.  сообщить("Выберите номер! Печать невозможна.");
  44.  возврат;
  45.  конецесли;

  1.  Если Вылет_туда.выбран()=0 тогда
  2.  сообщить("Выберите аэропорт вылета! Печать невозможна.");
  3.  возврат;
  4.  конецесли;  
  5.  Если ПустоеЗначение(Прибытие_туда)=1 тогда
  6.  сообщить("Выберите значение Мед.страх! Печать невозможна.");
  7.  возврат;
  8.  конецесли;
  9.  Если ФИО_Сотр.выбран()=0 тогда
  10.  сообщить("Выберите сотрудника, заключившего договор! Печать невозможна.");
  11.  возврат;
  12.  конецесли;
  13.  Если ПустоеЗначение(Прибытие)=1 тогда
  14.  сообщить("Введите дату прибытия! Печать невозможна.");
  15.  возврат;
  16.  конецесли;
  17.  Если ПустоеЗначение(Отъезд)=1 тогда
  18.  сообщить("Введите дату отъезда! Печать невозможна.");
  19.  возврат;
  20.  конецесли;
  21.  Таб = СоздатьОбъект("Таблица");
  22.  Таб.ИсходнаяТаблица("Заявка");
  23.  Ночи = Отъезд - Прибытие;
  24.  Таб.ВывестиСекцию("Шапка");
  25.  ВыбратьСтроки();
  26.  п=0;
  27.  Пока ПолучитьСтроку()=1 цикл
  28.  п = п + 1;
  29.  Таб.ВывестиСекцию("Строка");
  30.  Конеццикла;    
  31.  Таб.ВывестиСекцию("Подвал");
  32.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  33.  Таб.ТолькоПросмотр(1);
  34.  Таб.Показать("Печать заявки на бронирование тура","");
  35.  КонецПроцедуры


Код модуля документа:

  1.  Процедура ОбработкаПроведения()
  2.  Если (Номер_дог = "   -  /   ") или (Номер_дог = "          ") тогда
  3.  сообщить("Введите номер договора! Документ не проведен.");
  4.  непроводитьдокумент();
  5.  возврат;
  6.  конецесли;
  7.  Если Серия = "   №           " тогда
  8.  сообщить("Введите серию и номер путевки! Документ не проведен.");
  9.  непроводитьдокумент();             
  10.  возврат;
  11.  конецесли;
  12.  Если Тип = Перечисление.Тип_клиента.Физ_лицо тогда
  13.  Если Наименование_Клиента.выбран()=0 тогда
  14.  сообщить("Выберите клиента! Документ не проведен.");
  15.  непроводитьдокумент();
  16.  возврат;
  17.  конецесли;
  18.  ИначеЕсли Тип = Перечисление.Тип_клиента.Юр_лицо тогда
  19.  Если Юр_орг.выбран()=0 тогда
  20.  сообщить("Выберите клиента! Документ не проведен.");
  21.  непроводитьдокумент();
  22.  возврат;
  23.  конецесли;
  24.  Конецесли;
  25.  Если Цена_договора=0 тогда
  26.  сообщить("Не указана цена договора! Документ не проведен.");
  27.  непроводитьдокумент();
  28.  возврат;
  29.  конецесли;
  30.  Если Наим_туро.выбран()=0 тогда
  31.  сообщить("Выберите туроператора! Документ не проведен.");
  32.  непроводитьдокумент();
  33.  возврат;
  34.  конецесли;
  35.  Если курорт.выбран()=0 тогда
  36.  сообщить("Выберите куророт! Документ не проведен.");
  37.  непроводитьдокумент();
  38.  возврат;
  39.  конецесли;
  40.  Если Пансион.выбран()=0 тогда
  41.  сообщить("Выберите пансион! Документ не проведен.");
  42.  непроводитьдокумент();
  43.  возврат;
  44.  конецесли;
  45.  Если Номер.выбран()=0 тогда
  46.  сообщить("Выберите номер! Документ не проведен.");
  47.  непроводитьдокумент();
  48.  возврат;
  49.  конецесли;
  50.  Если Мед_Страх.выбран()=0 тогда
  51.  сообщить("Выберите значение Мед.страх! Документ не проведен.");
  52.  непроводитьдокумент();
  53.  возврат;
  54.  конецесли;
  55.  Если ПустоеЗначение(Прибытие)=1 тогда
  56.  сообщить("Введите дату прибытия! Документ не проведен.");
  57.  непроводитьдокумент();
  58.  возврат;
  59.  конецесли;
  60.  Если ПустоеЗначение(Отъезд)=1 тогда
  61.  сообщить("Введите дату отъезда! Документ не проведен.");
  62.  непроводитьдокумент();
  63.  возврат;
  64.  конецесли;
  65.  Если Самолет_туда.выбран()=0 тогда
  66.  сообщить("Выберите вид самолета! Документ не проведен.");
  67.  непроводитьдокумент();
  68.  возврат;
  69.  конецесли;   
  70.  Если Самолет_обр.выбран()=0 тогда
  71.  сообщить("Выберите вид самолета! Документ не проведен.");
  72.  непроводитьдокумент();
  73.  возврат;
  74.  конецесли;
  75.  Если Вылет_туда.выбран()=0 тогда
  76.  сообщить("Выберите аэропорт вылета! Документ не проведен.");
  77.  непроводитьдокумент();
  78.  возврат;
  79.  конецесли;  
  80.  Если ПустоеЗначение(Прибытие_туда)=1 тогда
  81.  сообщить("Выберите значение Мед.страх! Документ не проведен.");
  82.  непроводитьдокумент();
  83.  возврат;
  84.  конецесли;
  85.  Если ПустоеЗначение(Рейс_туда)=1 тогда  
  86.  сообщить("Введите номер рейса! Документ не проведен.");
  87.  непроводитьдокумент();
  88.  возврат;
  89.  конецесли;
  90.  Если ПустоеЗначение(Рейс_обр)=1 тогда
  91.  сообщить("Введите номер рейса! Документ не проведен.");
  92.  непроводитьдокумент();
  93.  возврат;
  94.  конецесли;
  95.  Если Рук_группы.выбран()=0 тогда
  96.  сообщить("Выберите значение: Наличие руководителя группы! Документ не проведен.");
  97.  непроводитьдокумент();
  98.  возврат;
  99.  конецесли;
  100.  Если Леч.выбран()=0 тогда
  101.  сообщить("Выберите значение: наличие лечения! Документ не проведен.");
  102.  непроводитьдокумент();
  103.  возврат;
  104.  конецесли;
  105.  Если Пустоезначение(Экс)=1 тогда
  106.  сообщить("Введите значение в поле Дополнительные экскурсии или поставьте нет! Документ не проведен.");
  107.  непроводитьдокумент();
  108.  возврат;
  109.  конецесли;
  110.  Если Пустоезначение(Доп)=1 тогда
  111.  сообщить("Выберите значение: Дополнительные оплаченные услуги или поставьте нет ! Документ не проведен.");
  112.  непроводитьдокумент();
  113.  возврат;
  114.  конецесли;
  115.  Если ФИО_Сотр.выбран()=0 тогда
  116.  сообщить("Выберите сотрудника, заключившего договор! Документ не проведен.");
  117.  непроводитьдокумент();
  118.  возврат;
  119.  конецесли;                         
  120.  Регистр.Продажа.Привязыватьстроку(1);
  121.  Выбратьстроки();
  122.  Пока Получитьстроку() = 1 Цикл
  123.  Регистр.Продажа.Курорт = Курорт;
  124.  Регистр.Продажа.Страна = Страна;
  125.  Регистр.Продажа.Цена = Цена_договора;
  126.  Регистр.Продажа.ДвижениеПриходВыполнить();
  127.  КонецЦикла;
  128.  КонецПроцедуры

Документ имеет следующие печатные формы:

Рис.15 Внешний вид договора для физических лиц.

Рис.16 Внешний вид договора для юридических лиц.

Рис. 17 Внешний вид акта для физических лиц.

Рис. 18 Внешний вид акта для юридических лиц. 

Рис. 19 Внешний вид Приложения 2 к договору.

Рис. 20 Внешний вид  Приложения к Путевке.


Рис. 21 Внешний вид  оборотной стороны листа Приложения к Путевке.

Рис. 21 Внешний вид  памятки о высокопатогенном гриппе.

Рис. 22 Внешний вид заявки на бронирование тура.


Документ « Акт выполненных работ».

Приложение 2.

Код модуля формы:

  1.  ПроцедураПриОткрытии()
  2.  ПриЗаписиПерепроводить(1);
  3.  Исполнитель="НОфондМониторинг";
  4.  Адрес_исп="249038г.Обнинскул.Гурьяновад.19";
  5.  КонецПроцедуры
  6.  ПроцедураАвт()
  7.  Цена=Договор.Цена_договора;
  8.  Ед_изм="шт";
  9.  Колво="1";
  10.  Сумма=Цена;
  11.  Предмет_счета="Предоставлениеуслугпоорганизациисанаторно-курортноголечениясотрудниковпредприятия"
  12.  КонецПроцедуры
  13.  ПроцедураАвтоподстановка()
  14.  Еслидоговор.тип=перечисление.тип_клиента.физ_лицотогда
  15.  Сообщить("ДанныйтипдокументаимеетсмыслтолькодляЮридическихлиц!Выберитедругойдоговор!");
  16.  Договор="";
  17.  Возврат;
  18.  Иначе
  19.  Клиент=Договор.Юр_орг;
  20.  Адрес=Клиент.Юр_адрес;
  21.  Дат_Дог=ДатаДок;
  22.  Номер_дог=Договор.Номер_дог;
  23.  Авт();
  24.  КонецЕсли
  25.  КонецПроцедуры
  26.  ПроцедураПечать()
  27.  Таб=СоздатьОбъект("Таблица");
  28.  Таб.ИсходнаяТаблица("Таблица");
  29.  ЕслиПустоезначение(договор)=1тогда
  30.  Сообщить("Выберитеномердоговора!Печатьневозможна!");
  31.  Возврат;
  32.  ИначеЕслиПустоезначение(Номер_акта)=1тогда
  33.  Сообщить("Выберитеномеракта!Печатьневозможна!");
  34.  Возврат;
  35.  ИначеЕслиКоличествоСтрок()<>1тогда
  36.  Сообщить("Предметсчетаможетбытьтолькоодин!Печатьневозможна!");
  37.  НеПроводитьДокумент();
  38.  Возврат;
  39.  Иначе
  40.  СуммаПрописью=Формат(Цена,"ЧПДС");
  41.  Пропись("");
  42.  ДатаПрописью=Формат(Дат_Дог,"Д(0)ДДММММГГГГ");
  43.  Таб.ВывестиСекцию("Акт");

  1.  Таб.ПараметрыСтраницы(2,,,,,0,0,,,1);
  2.  Таб.ТолькоПросмотр(1);
  3.  Таб.Показать("Печатьактавыполненныхработ","");
  4.  КонецЕсли;

  1.  КонецПроцедуры

Код модуля документа:

  1.  Процедура ОбработкаПроведения()
  2.  Если Пустоезначение(договор) = 1 тогда
  3.  Сообщить("Выберите номер договора! Документ не проведен!");
  4.  НеПроводитьДокумент();
  5.  Возврат;
  6.  ИначеЕсли Пустоезначение(Номер_акта) = 1 тогда
  7.  Сообщить("Выберите номер акта! Документ не проведен!");
  8.  НеПроводитьДокумент();
  9.  Возврат;

  1.  ИначеЕсли КоличествоСтрок() <> 1 тогда
  2.  Сообщить("Предмет счета может быть только один!Документ не проведен!");
  3.  НеПроводитьДокумент();
  4.  Возврат;             
  5.  КонецЕсли;

  1.  Регистр.Продажа.Привязыватьстроку(1);

  1.  Выбратьстроки();

  1.  Пока Получитьстроку() = 1 Цикл

  1.  Регистр.Продажа.Цена = Цена;

  1.  Регистр.Продажа.ДвижениеПриходВыполнить();

  1.  КонецЦикла;
  2.  КонецПроцедуры

Печатная форма данного документа:

Рис. 23 Внешний вид печатной формы акта.


Отчеты.

Приложение 3.

Отчет по заключенным договорам за период (Статистика).

Рис. 24 Внешний вид печатной формы отчета.

Код модуля:

  1.  // Процедура генерации запроса Сформировать.
  2.  Процедура Сформировать()
  3.  Перем Запрос, ТекстЗапроса, Таб;
  4.  если пустоезначение(ВыбНачПериода)=1 тогда
  5.  сообщить("Выберете начальную дату формирования отчета!");
  6.  возврат;    
  7.  конецесли;
  8.  если пустоезначение(ВыбКонПериода)=1 тогда
  9.  сообщить("Выберете конечную дату формирования отчета!");
  10.  возврат;     
  11.  конецесли;
  12.  если(ВыбКонПериода)<(ВыбНачПериода) тогда
  13.  сообщить("Неправельный диапазон дат!");
  14.  возврат;     
  15.  конецесли;
  16.  //Создание объекта типа Запрос
  17.  Запрос = СоздатьОбъект("Запрос");
  18.  ТекстЗапроса =
  19.  "//{{ЗАПРОС(Сформировать)
  20.  |Период с ВыбНачПериода по ВыбКонПериода;
  21.  |Обрабатывать НеПомеченныеНаУдаление;
  22.  |Договор = Документ.Договор.ТекущийДокумент;
  23.  |Номер_дог = Документ.Договор.Номер_дог;
  24.  |ДатаДок = Документ.Договор.ДатаДок;
  25.  |Функция ДоговорЦена_договораСумма = Сумма(Договор.Цена_договора);
  26.  |Группировка Договор упорядочить по Договор.Курорт, Договор.Номер_дог, Договор.ДатаДок без групп все ВошедшиеВЗапрос;
  27.  |"//}}ЗАПРОС
  28.  ;
  29.  // Если ошибка в запросе, то выход из процедуры
  30.  Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
  31.  Возврат;
  32.  КонецЕсли;
  33.  // Подготовка к заполнению выходных форм данными запроса
  34.  Таб = СоздатьОбъект("Таблица");
  35.  Таб.ИсходнаяТаблица("Сформировать");
  36.  // Заполнение полей "Заголовок"
  37.  Таб.ВывестиСекцию("Заголовок");
  38.  Состояние("Заполнение выходной таблицы...");
  39.  Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
  40.  Пока Запрос.Группировка(1) = 1 Цикл
  41.  // Заполнение полей Договор
  42.  Таб.ВывестиСекцию("Договор");
  43.  КонецЦикла;
  44.  // Заполнение полей "Итого"
  45.  Таб.ВывестиСекцию("Итого");
  46.  // Вывод заполненной формы
  47.  Таб.ТолькоПросмотр(1);
  48.  Таб.Показать("Сформировать", "");
  49.  КонецПроцедуры

Суммы заключенных договоров (Отчет по клиентам).

Рис. 25 Внешний вид печатной формы отчета.

Код модуля:

  1.  Процедура ПриОткрытии()  
  2.  ВТип = Перечисление.Тип_клиента.Физ_лицо;
  3.  КонецПроцедуры     
  4.  Процедура ВалидацияДат()
  5.  Если ВыбНачПериода > ВыбКонПериода Тогда
  6.  ВыбКонПериода = ВыбНачПериода;
  7.  ИначеЕсли ВыбНачПериода < ТекущаяДата() тогда
  8.  ВыбНачПериода = ТекущаяДата();
  9.  КонецЕсли
  10.  КонецПроцедуры
  11.  Процедура Сформировать()
  12.  Таб = СоздатьОбъект("Таблица");
  13.  Таб.ИсходнаяТаблица("Сформировать");
  14.  Таб.ВывестиСекцию("Шапка");
  15.  Таб.Опции(0,0,0,0);
  16.  Таб.ТолькоПросмотр(1);
  17.  Таб.Показать("Сформировать","");
  18.  КонецПроцедуры  
  19.  // Процедура генерации запроса Сформиро.
  20.  Процедура Сформиро()
  21.  Перем Запрос, ТекстЗапроса, Таб;
  22.  //Создание объекта типа Запрос
  23.  Запрос = СоздатьОбъект("Запрос");
  24.  Если ВТип = Перечисление.Тип_Клиента.Физ_лицо тогда
  25.  Текстзапроса = "                         
  26.  |Период с ВыбНачПериода по ВыбКонПериода;
  27.  |Договор = Документ.Договор.ТекущийДокумент;
  28.  |Наименование_Клиента = Документ.Договор.Наименование_Клиента;
  29.  |Тип = Документ.Договор.Тип;
  30.  |Функция ДоговорЦена_договораСумма = Сумма(Договор.Цена_договора);
  31.  |Группировка Договор упорядочить по Договор.Наименование_Клиента;          
  32.  |Условие(Тип = ВТип);";
  33.  Иначе
  34.  Текстзапроса = "                          
  35.  |Период с ВыбНачПериода по ВыбКонПериода;
  36.  |Договор = Документ.Договор.ТекущийДокумент;
  37.  |Юр_орг = Документ.Договор.Юр_орг;
  38.  |Тип = Документ.Договор.Тип;
  39.  |Функция ДоговорЦена_договораСумма = Сумма(Договор.Цена_договора);        
  40.  |Группировка Юр_орг упорядочить по Юр_орг.Наименование все ВошедшиеВЗапрос;
  41.  |Условие(Тип = ВТип);";
  42.  КонецЕсли;  
  43.  // Если ошибка в запросе, то выход из процедуры
  44.  Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
  45.  Возврат;
  46.  КонецЕсли;
  47.  // Подготовка к заполнению выходных форм данными запроса
  48.  Таб = СоздатьОбъект("Таблица");
  49.  Таб.ИсходнаяТаблица("Сформиро");
  50.  // Заполнение полей "Заголовок"
  51.  Таб.ВывестиСекцию("Заголовок");
  52.  Состояние("Заполнение выходной таблицы...");
  53.  Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
  54.  Если ВТип = Перечисление.Тип_Клиента.Физ_лицо тогда
  55.  Пока Запрос.Группировка(1) = 1 Цикл
  56.  // Заполнение полей Физ_лица
  57.  Таб.ВывестиСекцию("Физ_лица");
  58.  КонецЦикла;
  59.  ИначеЕсли ВТип = Перечисление.Тип_Клиента.Юр_лицо тогда
  60.  Пока Запрос.Группировка(1) = 1 Цикл
  61.  // Заполнение полей Юр_орг
  62.  Таб.ВывестиСекцию("Юр_орг");
  63.  КонецЦикла;
  64.  КонецЕсли;
  65.  // Заполнение полей "Итого"
  66.  Таб.ВывестиСекцию("Итого");
  67.  // Вывод заполненной формы
  68.  Таб.ТолькоПросмотр(1);
  69.  Таб.Показать("Отчет по клиентам", "");
  70.  КонецПроцедуры

Информация о путешествиях.

Рис. 26 Внешний вид печатной формы отчета.

Код модуля:

  1.  Процедура Переключать()

  1.  //переключатель слоя в зависимости от типа клиента
  2.  Если ВыбТип_клиента = Перечисление.Тип_Клиента.Физ_лицо Тогда
  3.  Форма.в_орг.Видимость(0);
  4.  Форма.ВыбЮрЛица.Видимость(0);
  5.  Форма.ВыбФизЛица.Видимость(1);
  6.  Форма.В_к.Видимость(1);
  7.  Форма.отчет_ю.Видимость(0);
  8.  Форма.отчет_ф.Видимость(1);

  1.  Иначе
  2.  ВыбТип_клиента = Перечисление.Тип_Клиента.Юр_лицо;
  3.  Форма.в_орг.Видимость(1);
  4.  Форма.ВыбЮрЛица.Видимость(1);
  5.  Форма.ВыбФизЛица.Видимость(0);
  6.  Форма.В_к.Видимость(0);
  7.  Форма.отчет_ю.Видимость(1);
  8.  Форма.отчет_ф.Видимость(0);
  9.  КонецЕсли;         
  10.  КонецПроцедуры
  11.  Процедура ПриОткрытии()
  12.  ВыбТип_клиента = Перечисление.Тип_Клиента.Физ_лицо;
  13.  Переключать()
  14.  КонецПроцедуры   
  15.  Процедура ВалидацияДат()
  16.  Если ВыбНачПериода > ВыбКонПериода Тогда
  17.  ВыбКонПериода = ВыбНачПериода;
  18.  ИначеЕсли ВыбНачПериода < ТекущаяДата() тогда
  19.  ВыбНачПериода = ТекущаяДата();
  20.  КонецЕсли
  21.  КонецПроцедуры
  22.  //
  23.  Процедура отчет()
  24.  Перем Запрос, ТекстЗапроса, Таб;
  25.  //Создание объекта типа Запрос
  26.  Если ВыбЮрЛица.выбран()=0 тогда
  27.  сообщить("Выберите клиента!");
  28.  Возврат;
  29.  КонецЕсли;
  30.  Запрос = СоздатьОбъект("Запрос");
  31.  ТекстЗапроса =
  32.  "//{{ЗАПРОС(отчет)
  33.  |Период с ВыбНачПериода по ВыбКонПериода;
  34.  |Обрабатывать НеПомеченныеНаУдаление;
  35.  |Курорт = Документ.Договор.Курорт;
  36.  |Цена_договора = Документ.Договор.Цена_договора;
  37.  |ДатаДок = Документ.Договор.ДатаДок;
  38.  |Номер_дог = Документ.Договор.Номер_дог;
  39.  |Юр_орг = Документ.Договор.Юр_орг;
  40.  |Тип = Документ.Договор.Тип;
  41.  |Группировка Юр_орг без групп все ВошедшиеВЗапрос;
  42.  |Группировка Курорт без групп;
  43.  |Группировка Номер_дог;
  44.  |Группировка ДатаДок;
  45.  |Группировка Цена_договора;
  46.  |Условие(Юр_орг = ВыбЮрЛица);
  47.  |Условие(Тип = ВыбТип_клиента);
  48.  |"//}}ЗАПРОС
  49.  ;
  50.  // Если ошибка в запросе, то выход из процедуры
  51.  Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
  52.  Возврат;
  53.  КонецЕсли;
  54.  // Подготовка к заполнению выходных форм данными запроса
  55.  Таб = СоздатьОбъект("Таблица");
  56.  Таб.ИсходнаяТаблица("отчет");
  57.  // Заполнение полей "Заголовок"
  58.  Таб.ВывестиСекцию("Заголовок");
  59.  Состояние("Заполнение выходной таблицы...");
  60.  Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
  61.  Пока Запрос.Группировка(1) = 1 Цикл
  62.  // Заполнение полей Юр_орг
  63.  //Таб.ВывестиСекцию("Юр_орг");
  64.  Пока Запрос.Группировка(2) = 1 Цикл
  65.  // Заполнение полей Курорт
  66.  //Таб.ВывестиСекцию("Курорт");
  67.  Пока Запрос.Группировка(3) = 1 Цикл
  68.  // Заполнение полей Номер_дог
  69.  //Таб.ВывестиСекцию("Номер_дог");
  70.  Пока Запрос.Группировка(4) = 1 Цикл
  71.  // Заполнение полей ДатаДок
  72.  //Таб.ВывестиСекцию("ДатаДок");
  73.  Пока Запрос.Группировка(5) = 1 Цикл
  74.  // Заполнение полей Цена_договора
  75.  Таб.ВывестиСекцию("Цена_договора");
  76.  КонецЦикла;
  77.  КонецЦикла;
  78.  КонецЦикла;
  79.  КонецЦикла;
  80.  КонецЦикла;
  81.  // Вывод заполненной формы
  82.  Таб.ТолькоПросмотр(1);
  83.  Таб.Показать("Отчет по Юр.лицам", "");
  84.  КонецПроцедуры  
  85.  //*******************************************
  86.  // Процедура генерации запроса Физлица.
  87.  //
  88.  Процедура Физлица()
  89.  Перем Запрос, ТекстЗапроса, Таб;
  90.  //Создание объекта типа Запрос  
  91.  Если ВыбФизЛица.выбран()=0 тогда
  92.  сообщить("Выберите клиента!");
  93.  Возврат;
  94.  КонецЕсли;
  95.  Запрос = СоздатьОбъект("Запрос");
  96.  ТекстЗапроса =
  97.  "//{{ЗАПРОС(Физлица)
  98.  |Период с ВыбНачПериода по ВыбКонПериода;
  99.  |Обрабатывать НеПомеченныеНаУдаление;
  100.  |Курорт = Документ.Договор.Курорт;
  101.  |Наименование_Клиента = Документ.Договор.Наименование_Клиента;
  102.  |ДатаДок = Документ.Договор.ДатаДок;
  103.  |Номер_дог = Документ.Договор.Номер_дог;
  104.  |Тип = Документ.Договор.Тип;
  105.  |Цена_договора = Документ.Договор.Цена_договора;
  106.  |Группировка Наименование_Клиента;
  107.  |Группировка Курорт;
  108.  |Группировка Номер_дог;
  109.  |Группировка ДатаДок;
  110.  |Группировка Цена_договора;
  111.  |Условие(Тип = ВыбТип_клиента);
  112.  |Условие(Наименование_Клиента = ВыбФизЛица);
  113.  |"//}}ЗАПРОС;
  114.  // Если ошибка в запросе, то выход из процедуры
  115.  Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
  116.  Возврат;
  117.  КонецЕсли;
  118.  // Подготовка к заполнению выходных форм данными запроса
  119.  Таб = СоздатьОбъект("Таблица");
  120.  Таб.ИсходнаяТаблица("Физлица");
  121.  // Заполнение полей "Заголовок"
  122.  Таб.ВывестиСекцию("Заголовок");
  123.  Состояние("Заполнение выходной таблицы...");
  124.  Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
  125.  Пока Запрос.Группировка(1) = 1 Цикл
  126.  // Заполнение полей Наименование_Клиента
  127.  //Таб.ВывестиСекцию("Наименование_Клиента");
  128.  Пока Запрос.Группировка(2) = 1 Цикл
  129.  // Заполнение полей Курорт
  130.  //Таб.ВывестиСекцию("Курорт");
  131.  Пока Запрос.Группировка(3) = 1 Цикл
  132.  // Заполнение полей Номер_дог
  133.  //Таб.ВывестиСекцию("Номер_дог");
  134.  Пока Запрос.Группировка(4) = 1 Цикл
  135.  // Заполнение полей ДатаДок
  136.  //Таб.ВывестиСекцию("ДатаДок");
  137.  Пока Запрос.Группировка(5) = 1 Цикл
  138.  // Заполнение полей Цена_договора
  139.  Таб.ВывестиСекцию("Цена_договора");
  140.  КонецЦикла;
  141.  КонецЦикла;
  142.  КонецЦикла;
  143.  КонецЦикла;
  144.  КонецЦикла;
  145.  // Вывод заполненной формы
  146.  Таб.ТолькоПросмотр(1);
  147.  Таб.Показать("Отчет по физ.лицам", "");
  148.  КонецПроцедуры


Справочник:

ФизЛица

Документ: Договор.

Справочник:

Туристы

окумент: Акт.

Справочник:

Сотрудники

Справочник:

Отели

Справочник:

Туры

Справочник:

Страны

Справочник:

Аэропорты

Справочник:

ЮрЛица

Справочник:

Авиакомпании

Справочник:

Туроператоры

Главная форма программы меню

Договор

Акт выполненных работ

ФизЛица

ЮрЛица

Туристы

Туроператоры

Сотрудники

Отели

Журналы документов

Справочники

Документы

Отчеты

Туры

Общий

Акты

Договоры

Статистика по направлениям

Отчет по клиентам

Все документы и отчеты имеют печатные формы

Страны

Аэропорты

Информация о путешествиях

Авиакомпании

  1.  


 

Другие похожие работы, которые могут вас заинтересовать.
18375. Система автоматизированного учета агенства недвижимости 513.65 KB
  В данной работе необходимо разработать программу а точнее систему управления базой данных какой-либо риэлторской фирмы для определенного города которая позволяет вносить удалять и изменять данные. Область применения: эта небольшая по размеру программа управления базой данных применима в основном для частных коммерческих организаций занимающихся непосредственно продажей недвижимости в частности квартир: однокомнатных двухкомнатных трехкомнатных и домов. На этапе разработки будущей системы именно ему необходимо определить объем и состав...
1682. Автоматизация учета товаров на предприятии 3.3 MB
  Все операции купли-продажи товаров осуществляются на основании договора купли-продажи и его разновидностей (договор поставки, договор розничной купли-продажи и т.п.). Операции по учету товаров для продажи и перепродажи ведутся в специализированных торговых организациях (магазинах, универмагах, универсамах и т. п.)
1674. АВТОМАТИЗАЦИЯ УЧЕТА РАБОТЫ АВТОТРАНСПОРТНОГО ПРЕДПРИЯТИЯ 1.08 MB
  Автотранспортное предприятие МП ОПАТП осуществляет пассажирские перевозки, сопровождая плановые рейсы формированием определенной документации: формирование маршрутного журнала, листа-дохода кондукторов, учёт рабочего времени водителей.
1675. Автоматизация учета в кафе-баре (Ресторане) 1.18 MB
  В табличной части документа после выбора номенклатуры устанавливается закупочная цена потом процент наценки. При установке документом новых значений покупной и продажной цены они сохраняются и используются в дальнейшем для автоматической подстановки в данные строки табличной части документа при выборе соответствующей позиции номенклатуры. Помимо оприходования товаров от поставщиков в случае изменения продажных цен осуществляется автоматическая переоценка остатков данного вида номенклатуры по всем партиям по всем складам. документ...
11199. Автоматизация учета основных средств на предприятии 5.71 MB
  Система программ 1С: Предприятие предназначена для автоматизации управления и учета на предприятиях различных отраслей, видов деятельности и типов финансирования, и включает в себя решения для комплексной автоматизации производственных, торговых и сервисных предприятий,
15509. АВТОМАТИЗАЦИЯ УЧЁТА ПРИЁМА и ВЫДАЧИ КНИГ В БИБЛИОТЕКЕ 187.67 KB
  Библиотечный процесс книговыдачи построен на базе локальной компьютерной сети которая объединяет все технологические операции работы с изданием библиотеки ее фондом. Процесс автоматизации деятельности библиотеки должен позволить и обеспечить: доступ к удаленным базам данных для возможности заказа книг из других фондов библиотек достаточно быстрый процесс выдачи и приема книг. автоматизированный учет должников заказ литературы с использованием базы данных рекомендованных пособий быстроту поиска необходимой читателю...
1658. Разработка программного обеспечения «Автоматизация учета компьютерной техники» 761.5 KB
  Неотъемлемым условием успешного долгосрочного функционирования предприятия является высокая степень интеграции технологий управления и автоматизация работы отделов. Для упрощения работы и повышения работоспособности сотрудников информационно вычислительного центра необходимо разработать программный продукт
1771. Автоматизация процесса бухгалтерского учета товарно-материальных ценностей 240.83 KB
  Шаг бизнеспроцесса Описание Исполнитель Счет от поставщика Бухгалтеру поступает счет от поставщика ТМЦ Бухгалтер Проверка закупка от плательщиков ли НДС Проверка платит ли поставщик ТМЦ налог на добавленную стоимость или нет Бухгалтер Платежное поручение с НДС При условии что поставщик является плательщиком НДС формируется платежное поручение с учетом НДС Бухгалтер Платежное поручение без НДС При условии что поставщик не является плательщиком НДС формируется платежное поручение без учета НДС Бухгалтер Банковская выписка...
1683. Автоматизация учета финансово-расчетных операций (УФРО) на предприятии 1.02 MB
  Учет денежных средств в кассе предприятия. Машинно-ориентированная форма бухгалтерского учета ориентируется на использование ПК средств сбора регистрации и передачи данных для обработки учетной информации. Функционирование АРМ бухгалтера по учету финансово-расчетных операций должно обеспечить в диалоговом режиме учет контроль за финансовыми операциями отражающими ежедневное состояние предприятия выполнение необходимых расчетов по анализу финансового состояния с целью определения резервов ускорения оборачиваемости денежных...
1676. НА ТЕМУ: АВТОМАТИЗАЦИЯ Учета централизованных поставок продуктов питания в школы ГОРОДА обнинска. 388.63 KB
  Одна из основных целей системы обработки данных заключается в повышении эффективности работы компании. Взаимосвязь показана в схеме данных: Как правило разработка проекта реализации задачи выполняется в несколько этапов и начинается с анализа той информации которая является выходной формы и отчеты для OpenOffice. Только после выяснения структуры и состава этой информации формулировки запросов для получения отчетов можно сделать вывод о структуре и составе таблиц данных. Необходимым этапом формализации задачи является нормализация базы...
© "REFLEADER" http://refleader.ru/
Все права на сайт и размещенные работы
защищены законом об авторском праве.