Основы автоматизированного бухгалтерского учета

Оплата покупателя поступает общей суммой по нескольким накладным (накладные указываются в табличной части, сумма в шапке). При проведении документа оплаты должны автоматически распределяться по накладным, начиная с самой ранней недооплаченной...

2014-06-23

1 MB

12 чел.


Поделитесь работой в социальных сетях

Если эта работа Вам не подошла внизу страницы есть список похожих работ. Так же Вы можете воспользоваться кнопкой поиск


Федеральное государственное бюджетное образовательное  учреждение

высшего профессионального образования

“ВОЛГОГРАДСКИЙ ГОСУДАРСТВЕННЫЙ ТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ”

Факультет подготовки инженерных кадров

Кафедра САПР и ПК

КОНТРОЛЬНАЯ РАБОТА

по курсу

«Основы автоматизированного бухгалтерского учета»

Выполнил:

студент гр. АУЗ-461с

_____________ И.А.Тюляева

«___» ___________ 2014г

Проверил:

Проф. каф. САПР и ПК,

доктор технических наук

_____________ Кравец А.Г.

«___» __________ 2014г.

Волгоград, 2014

Содержание

[0.0.1] КОНТРОЛЬНАЯ РАБОТА

[1] Содержание

[2] Задание 1.40

[3] Справочники.

[4] Документы и регистры.

[5] Отчеты.


Задание 1.40

Организация занимается торговлей скоропортящимися продуктами. Для каждого товара указывается норма естественной убыли при транспортировке. Доставка товара покупателю отражается документом «Расходная накладная», оплата покупателя - документом «Приход денег». При получении товара покупатель по каждой накладной составляет акт (документ «Акт приема-передачи товаров»), о фактическом поступлении товара, за вычетом испортившегося при транспортировке.

В том случае, когда потери товара не превышают нормы естественной убыли, покупатель оплачивает весь товар. Если потери товара превышают нормы, то покупатель оплачивает только фактически полученный товар.

Оплата покупателя поступает общей суммой по нескольким накладным (накладные указываются в табличной части, сумма в шапке). При проведении документа оплаты должны автоматически распределяться по накладным, начиная с самой ранней недооплаченной, причем оплаты должны распределяться с учетом фактической задолженности покупателя. Следует считать, что переплат и авансов нет.

Учет товаров ведется в разрезе складов. Отгрузка по одной накладной возможна только по одному складу (склад реквизит шапки). Стоимость товаров рассчитывается как средняя по складу.  

Необходимо создать отчеты о состоянии взаиморасчетов с покупателями и отгрузках товаров за период.

Взаиморасчеты с покупателями за период с 01.01.2009 по 31.03.2009

Покупатель

Документ

Нач. Задолж.

Отгрузка

Оплата

Кон. задолж.

Красный цветок

1000

1200

800

1400

Расх. Накл № 4

500

Расх. Накл. №6

700

Приход денег №2

800

Красный октябрь

1000

1000

Расх. Накл. №3

1000

Приход денег №3

1000

В отчете должна отражаться сумма отгрузок, которые должен оплатить покупатель, с учетом убыли.

Отгрузки товаров за период с 01.01.2009 по 31.03.2009

Товар

Отгружено

Потери в

Потери сверх

фактически

пределах норм

норм

Куртка замшевая

10

2

1

Портсигар

50

5

Фактически отгруженное количество должно отображать общее количество товаров, отгруженных нами покупателю, без учета того, сколько он реально получил.


Справочники.

  1.  Справочник «Номенклатура» – предназначен для хранения информации о товарах.

  1.  Справочник «Контрагенты» –  предназначен для хранения базы данных организаций и физических лиц, с которыми компания вступает в расчетные отношения.

  1.  Справочник «Склады» –  предназначен для ведения списка мест хранения товарно-материальных ценностей.

Документы и регистры.

  1.  Документ «Расходная накладная» предназначен для отражения операций по реализации товаров.

Модуль объекта:

Процедура ОбработкаПроведения(Отказ, Режим)

Движения.Взаиморасчеты.Записывать = Истина;

Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл

 Движение = Движения.Взаиморасчеты.Добавить();

 Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

 Движение.Период = Дата;

 Движение.Контрагент = Контрагент;

 Движение.Документ = Ссылка;

 Движение.Сумма = СуммаПоДокументу;

КонецЦикла;

 

Движения.ОтгрузкиТоваров.Записывать = Истина;

Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл

 Движение = Движения.ОтгрузкиТоваров.Добавить();

 Движение.Период = Дата;

 Движение.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;

 Движение.КоличествоОтправлено = ТекСтрокаСписокНоменклатуры.Количество;

КонецЦикла;

КонецПроцедуры

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

СуммаПоДокументу = СписокНоменклатуры.Итог("Сумма");

КонецПроцедуры

  1.  Документ «Приход денег» – предназначен для добавления нового поступления денег и сведений о нем.

Модуль объекта:

Процедура ОбработкаПроведения(Отказ, Режим)

Движения.Взаиморасчеты.Записать();

Движения.Взаиморасчеты.Записывать = Истина;

 

Блокировка = Новый БлокировкаДанных;

ЭлементБлокировки = Блокировка.Добавить("РегистрНакопления.Взаиморасчеты");

ЭлементБлокировки.УстановитьЗначение("Контрагент", Контрагент);

ЭлементБлокировки.Режим = РежимБлокировкиДанных.Исключительный;

ЭлементБлокировки.ИсточникДанных = СписокНакладных;

ЭлементБлокировки.ИспользоватьИзИсточникаДанных("Документ", "Накладная");

Блокировка.Заблокировать();

 

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ

               | ПриходДенегСписокНакладных.Накладная КАК Накладная

               |ПОМЕСТИТЬ ВТСписок

               |ИЗ

               | Документ.ПриходДенег.СписокНакладных КАК ПриходДенегСписокНакладных

               |ГДЕ

               | ПриходДенегСписокНакладных.Ссылка = &Ссылка

               |

               |ИНДЕКСИРОВАТЬ ПО

               | Накладная

               |;

               |

               |////////////////////////////////////////////////////////////////////////////////

               |ВЫБРАТЬ

               | ВТСписок.Накладная,

               | ЕСТЬNULL(ВзаиморасчетыОстатки.СуммаОстаток, 0) КАК СуммаОстаток

               |ИЗ

               | ВТСписок КАК ВТСписок

               |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.Взаиморасчеты.Остатки(

               |    &Момент,

               |    Документ В

               |      (ВЫБРАТЬ

               |       Т.Накладная

               |      ИЗ

               |       ВТСписок КАК Т)

               |     И Контрагент = &Контрагент) КАК ВзаиморасчетыОстатки

               |  ПО ВТСписок.Накладная = ВзаиморасчетыОстатки.Документ

               |

               |УПОРЯДОЧИТЬ ПО

               | ВТСписок.Накладная.МоментВремени

               |ИТОГИ

               | СУММА(СуммаОстаток)

               |ПО

               | ОБЩИЕ";

Запрос.УстановитьПараметр("Ссылка", Ссылка);

Запрос.УстановитьПараметр("Момент", ?(Режим = РежимПроведенияДокумента.Неоперативный, МоментВремени(), Неопределено));

Запрос.УстановитьПараметр("Контрагент", Контрагент);

Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

 

Если Выборка.Следующий() Тогда

 Превышение = СуммаПоДокументу + Выборка.СуммаОстаток;

 Если Превышение > 0 Тогда

  Отказ = Истина;

  Сообщить("Сумма оплаты превышает имеющуюся задолженность на " + Превышение);

  Возврат;

 КонецЕсли;

КонецЕсли;

 

ВыборкаДет = Выборка.Выбрать();

СуммаРаспределения = СуммаПоДокументу;

 

Пока ВыборкаДет.Следующий() И СуммаРаспределения > 0 Цикл

 

 ТекСумма = Мин(СуммаРаспределения, -ВыборкаДет.СуммаОстаток);

 

 Движение = Движения.Взаиморасчеты.Добавить();

 Движение.ВидДвижения = ВидДвиженияНакопления.Приход;

 Движение.Период = Дата;

 Движение.Контрагент = Контрагент;

 Движение.Документ = ВыборкаДет.Накладная;

 Движение.Сумма = ТекСумма;

 

 СуммаРаспределения = СуммаРаспределения - ТекСумма;

 

КонецЦикла;

КонецПроцедуры

  1.  Документ «Акт приема-передачи» предназначен для фиксации факта передачи документов от одной стороны другой.

Модуль объекта:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)

//{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

// Данный фрагмент построен конструктором.

// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.РасходнаяНакладная") Тогда

 // Заполнение шапки

 Накладная = ДанныеЗаполнения.Ссылка;

 Контрагент = ДанныеЗаполнения.Контрагент;

 Для Каждого ТекСтрокаСписокНоменклатуры Из ДанныеЗаполнения.СписокНоменклатуры Цикл

  НоваяСтрока = СписокНоменклатуры.Добавить();

  НоваяСтрока.КоличествоОтправлено = ТекСтрокаСписокНоменклатуры.Количество;

  НоваяСтрока.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;

  НоваяСтрока.Сумма = ТекСтрокаСписокНоменклатуры.Сумма;

  НоваяСтрока.Цена = ТекСтрокаСписокНоменклатуры.Цена;

 КонецЦикла;

КонецЕсли;

//}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, Режим)

// регистр ОтгрузкиТоваров

Движения.ОтгрузкиТоваров.Записывать = Истина;

Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл

 Движение = Движения.ОтгрузкиТоваров.Добавить();

 Движение.Период = Дата;

 Движение.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;

 Движение.КоличествоПолучено = ТекСтрокаСписокНоменклатуры.КоличествоПолучено;

КонецЦикла;

// Снижение долга при недопоставке

Движения.Взаиморасчеты.Записать();

Движения.Взаиморасчеты.Записывать = Истина;

 

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ

               | АктПриемаПередачиСписокНоменклатуры.Номенклатура КАК Номенклатура,

               | СУММА(АктПриемаПередачиСписокНоменклатуры.КоличествоОтправлено) КАК КоличествоОтправлено,

               | СУММА(АктПриемаПередачиСписокНоменклатуры.КоличествоПолучено) КАК КоличествоПолучено,

               | СУММА(АктПриемаПередачиСписокНоменклатуры.Цена) КАК Цена

               |ПОМЕСТИТЬ ВТСписок

               |ИЗ

               | Документ.АктПриемаПередачи.СписокНоменклатуры КАК АктПриемаПередачиСписокНоменклатуры

               |ГДЕ

               | АктПриемаПередачиСписокНоменклатуры.Ссылка = &Ссылка

               |

               |СГРУППИРОВАТЬ ПО

               | АктПриемаПередачиСписокНоменклатуры.Номенклатура

               |

               |ИНДЕКСИРОВАТЬ ПО

               | Номенклатура

               |;

               |

               |////////////////////////////////////////////////////////////////////////////////

               |ВЫБРАТЬ

               | ВТСписок.Номенклатура,

               | ВЫБОР

               |  КОГДА ВТСписок.КоличествоОтправлено - ВТСписок.КоличествоПолучено <= ВТСписок.КоличествоОтправлено * ЕСТЬNULL(НормыУбыли.НормаУбылиПроцент, 0) / 100

               |   ТОГДА 0

               |  ИНАЧЕ ВТСписок.КоличествоОтправлено - ВТСписок.КоличествоПолучено - ВТСписок.КоличествоОтправлено * ЕСТЬNULL(НормыУбыли.НормаУбылиПроцент, 0) / 100

               | КОНЕЦ КАК ПревышениеПотерь,

               | ВТСписок.Цена,

               | ВТСписок.КоличествоОтправлено - ВТСписок.КоличествоПолучено КАК ПотериФакт

               |ИЗ

               | ВТСписок КАК ВТСписок

               |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.НормыУбыли КАК НормыУбыли

               |  ПО ВТСписок.Номенклатура = НормыУбыли.Номенклатура";

Запрос.УстановитьПараметр("Ссылка", Ссылка);

Выборка = Запрос.Выполнить().Выбрать();

СнижениеДолга = 0;

 

Пока Выборка.Следующий() Цикл

 Если Выборка.ПревышениеПотерь > 0 Тогда

  СнижениеДолга = СнижениеДолга + Выборка.Цена * Выборка.ПотериФакт;

 КонецЕсли;

КонецЦикла;

 

Если СнижениеДолга > 0 Тогда  

 Движение = Движения.Взаиморасчеты.Добавить();

 Движение.ВидДвижения = ВидДвиженияНакопления.Приход;

 Движение.Период = Дата;

 Движение.Контрагент = Контрагент;

 Движение.Документ = Накладная;

 Движение.Сумма = СнижениеДолга;

КонецЕсли;;

КонецПроцедуры

  1.  Регистр накопления «Взаиморасчеты» – предназначен для хранения информации о взаимных расчетах с контрагентами.

  1.  Регистр накопления «Отгрузки товаров» – предназначен для хранения информации об отгрузках товаров контрагентам.

Отчеты.

  1.  Отчет «Отгрузки товаров» – предназначен для отображения информации об отгрузках товаров контрагентам.

Запрос:

ВЫБРАТЬ

ОтгрузкиТоваровОбороты.Номенклатура,

ОтгрузкиТоваровОбороты.КоличествоОтправленоОборот,

ОтгрузкиТоваровОбороты.КоличествоПолученоОборот,

ЕСТЬNULL(НормыУбыли.НормаУбылиПроцент, 0) * ОтгрузкиТоваровОбороты.КоличествоОтправленоОборот / 100 КАК ДопустимаяУбыль,

ОтгрузкиТоваровОбороты.КоличествоОтправленоОборот - ОтгрузкиТоваровОбороты.КоличествоПолученоОборот КАК ПотеряноФакт

ПОМЕСТИТЬ ВТСписок

ИЗ

РегистрНакопления.ОтгрузкиТоваров.Обороты КАК ОтгрузкиТоваровОбороты

 ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.НормыУбыли КАК НормыУбыли

 ПО ОтгрузкиТоваровОбороты.Номенклатура = НормыУбыли.Номенклатура

;

////////////////////////////////////////////////////////////////////////////////

ВЫБРАТЬ

ВТСписок.Номенклатура КАК Товар,

ВЫБОР

 КОГДА ВТСписок.ДопустимаяУбыль > ВТСписок.ПотеряноФакт

  ТОГДА ВТСписок.ПотеряноФакт

 ИНАЧЕ ВТСписок.ДопустимаяУбыль

КОНЕЦ КАК ПотериВПределахНорм,

ВЫБОР

 КОГДА ВТСписок.ДопустимаяУбыль > ВТСписок.ПотеряноФакт

  ТОГДА 0

 ИНАЧЕ ВТСписок.ПотеряноФакт - ВТСписок.ДопустимаяУбыль

КОНЕЦ КАК ПотериСверхНорм,

ВТСписок.КоличествоОтправленоОборот КАК ОтгруженоФактически

ИЗ

ВТСписок КАК ВТСписок

  1.  Отчет «Взаиморасчеты» – предназначен для отображения информации о взаимных расчетах с контрагентами.

Запрос:

ВЫБРАТЬ

ВзаиморасчетыОстаткиИОбороты.Регистратор.Накладная,

ВзаиморасчетыОстаткиИОбороты.СуммаПриход

ПОМЕСТИТЬ ВТ

ИЗ

РегистрНакопления.Взаиморасчеты.ОстаткиИОбороты(, , Регистратор, , ) КАК ВзаиморасчетыОстаткиИОбороты

ГДЕ

ВзаиморасчетыОстаткиИОбороты.Регистратор ССЫЛКА Документ.АктПриемаПередачи

;

////////////////////////////////////////////////////////////////////////////////

ВЫБРАТЬ

ВзаиморасчетыОстаткиИОбороты.Контрагент КАК Покупатель,

-ВзаиморасчетыОстаткиИОбороты.СуммаНачальныйОстаток КАК НачальнаяЗадолженность,

ВзаиморасчетыОстаткиИОбороты.СуммаПриход КАК Оплата,

ВзаиморасчетыОстаткиИОбороты.СуммаРасход - ЕСТЬNULL(ВТ.СуммаПриход, 0) КАК Отгрузка,

-ВзаиморасчетыОстаткиИОбороты.СуммаКонечныйОстаток КАК КонечнаяЗадолженность,

ВзаиморасчетыОстаткиИОбороты.Регистратор КАК Документ

ИЗ

РегистрНакопления.Взаиморасчеты.ОстаткиИОбороты(, , Регистратор, , ) КАК ВзаиморасчетыОстаткиИОбороты

 ЛЕВОЕ СОЕДИНЕНИЕ ВТ КАК ВТ

 ПО ВзаиморасчетыОстаткиИОбороты.Регистратор = ВТ.РегистраторНакладная

ГДЕ

НЕ ВзаиморасчетыОстаткиИОбороты.Регистратор ССЫЛКА Документ.АктПриемаПередачи



 

Другие похожие работы, которые могут вас заинтересовать.
1470. Основы банковского бухгалтерского учета 17.67 KB
  Банковская система в России на сегодняшний день - одна из наиболее развивающихся секторов рыночной экономики. Роль банка как социально-экономической структуры, влияющей на финансовые процессы в стране, тенденции развития банковского сектора в российской экономике
18375. Система автоматизированного учета агенства недвижимости 513.65 KB
  В данной работе необходимо разработать программу а точнее систему управления базой данных какой-либо риэлторской фирмы для определенного города которая позволяет вносить удалять и изменять данные. Область применения: эта небольшая по размеру программа управления базой данных применима в основном для частных коммерческих организаций занимающихся непосредственно продажей недвижимости в частности квартир: однокомнатных двухкомнатных трехкомнатных и домов. На этапе разработки будущей системы именно ему необходимо определить объем и состав...
14204. Теория бухгалтерского учета 92.42 KB
  Развитие рыночных отношений в РФ обозначает новые направления к подготовке специалистов управления крупным и малым бизнесом: руководителям, менеджерам, экономистам, финансистам, бухгалтерам, аналитикам, ревизорам, маркетологам. Данные специалисты, зная основы бухгалтерского учета и умея их применить в практической деятельности
7126. Принципы бухгалтерского учёта и отчётность 19.41 KB
  Принципы бухгалтерского учёта и отчётность Принципы бухгалтерского учета Понятие бухгалтерского баланса Строение бухгалтерского баланса. Регулярное балансовое обобщение которое предопределено такими элементами метода бухгалтерского учета как составление баланса и отчетности за год полугодие квартал месяц. Понятие бухгалтерского баланса. Структура баланса представляет собой двухстороннюю таблицу.
7100. Ведение счетов бухгалтерского учёта 21.51 KB
  Счета бухгалтерского баланса Двойная запись Четыре типа хозяйственных операций влияющих на статьи баланса. Счета бухгалтерского баланса Счета бухгалтерского учета являются способом группировки и текущего отражения в денежной оценке хозяйственных операций в результате которых изменяется состав средств актив баланса и их источников пассив баланса. Таким образом каждому счету со своим наименованием и цифровым номером или нескольким счетам соответствует определенная статья баланса. На основе...
979. Нормативное регулирование бухгалтерского учета 123.59 KB
  Сущность системы нормативного регулирования бухгалтерского учета Нормативное регулирование бухгалтерского учета в различных странах. Нормативное регулирование бухгалтерского учета в России.
1482. Анализ организации бухгалтерского учета ООО «РегионСтройМонтаж» 74.81 KB
  Особенности нормативного регулирования бухгалтерского учета материально-производственных запасов в Российской Федерации. Анализ организации бухгалтерского учета ООО Регион-Строй-Монтаж.
4475. Формирование отчетов и создание бухгалтерского учета 1.63 MB
  Откройте в конфигураторе окно редактирования объекта конфигурации Документ Приходная Накладная и перейдите на закладку Движения. В списке регистров отметьте что документ будет создавать теперь движения и по регистру Стоимость Материалов
18253. Организации бухгалтерского учета основных средств 107.83 KB
  Теоретические основы учета основных средств. Экономическая сущность основных средств их роль в условиях рыночной экономики. Классификация и оценка основных средств. Учет и аудит основных средств на предприятии: состояние и совершенствование.
17638. Ведение бухгалтерского учета на малом предприятии 42.08 KB
  Малое предприятие — вполне самостоятельная и наиболее типичная форма организации экономической жизни общества со своими отличительными особенностями, преимуществами и недостатками, закономерностями развития. Функционирование на локальном рынке, быстрое реагирование на изменение конъюнктуры этого рынка, непосредственная связь с потребителем
© "REFLEADER" http://refleader.ru/
Все права на сайт и размещенные работы
защищены законом об авторском праве.